Hot answers tagged

6

I had same exact situation. It seems that (and I did not see this documented anywhere) when using private mode, the private node must initiate the connection. In my case it was a firewall rule preventing the private node from establishing the connection, and after I permitted that everything worked great.


2

Use ./tezos-node config update --connections=300 to fix your config file, as Tom said, those numbers should not match. Then restart tezos-node. Make sure your firewall is open, and any routers are port-forwarding to port 9732. You should also enable the RPC while you are at it config update --rpc-addr=127.0.0.1:8732 so that you can use other tools which ...


1

I went to ~/tezos-delphinet/config.json and edited the default listen-addr to 9733: { "data-dir": "/home/user/tezos-delphinet", "p2p": { "bootstrap-peers": [ "delphinet.tezos.co.il", "delphinet.smartpy.io", "delphinet.kaml.fr", "13.53.41.201" ], "...


1

Indeed there is currently no mechanism to publish an IP different from the one you use to reach other nodes. If you want to have your machine connected through a tunnel via a public machine, you need to make your outgoing connections go through the same public machine so that the exposed IP given to the node you connect to is the one of the public machine. ...


1

The code uses IPv6, which must be enabled on the host, and was not in my case.


1

Make sure you are on most recent code checkout hash: $ git log -1 should give you the hash: 0639894412 (Feb 11 2020) I just did a complete rebuild of the source and I do not have tezos-p2p in the path you specified. This, $ find ./ -iname tezos-p2p, returns no results in the entire code tree. Additionally, looking at the build file (dune file) it says ...


Only top voted, non community-wiki answers of a minimum length are eligible