Hot answers tagged

8

Ok, i've tried to open ports, generated a new identity, added peers manually (like iguer) adviced, but nothing helped. But a guy called "Krixt" in the Tezos Baking slack wrote this script: #!/bin/bash # get foundation nodes for i in dubnodes franodes sinnodes nrtnodes pdxnodes; do for j in `dig $i.tzbeta.net +short`; do echo "Connecting ...


8

Is your node in private mode ? It's bizarre to only have 5 connections while there are hundreds of peers in the networks. Have you tried to restart your node ? and/or to generate a new identity ? Maybe the other nodes have blacklisted yours. You can either add peers with command line option --peer ADDR:PORT, or by adding them in the config.json file. Via ...


7

Some "just started node" sometime ends up in a situation like that and work is done to get rid of the problem. The scenario is the following: The bootstrap peers accept a big number of connection so there is never any problem to connect to them Then, they send back always the same subset of their peers. And these peers do not accept hundred of connection ...


3

You should set all three to 0 in order to accept 0-fee transactions. This will not affect the validity of the blocks you create. One possible negative repercussion is that your mempool could be spammed with very cheap transactions and the mempool isn't currently as sophisticated as it could be. However, if that happens you could revert to requiring more ...


2

As iguer pointed out, private mode would be one reason to cause this. But to elaborate, this happens mostly because private mode nodes are less favorable for a peer node to connect to as the private node is basically a leech to the network. It will not try to bootstrap other nodes. Private nodes will mostly just monitor to get the blockchain and fill its ...


2

Use ./tezos-node config update --connections=300 to fix your config file, as Tom said, those numbers should not match. Then restart tezos-node. Make sure your firewall is open, and any routers are port-forwarding to port 9732. You should also enable the RPC while you are at it config update --rpc-addr=127.0.0.1:8732 so that you can use other tools which ...


2

It is not possible to set the network in the config.json file. The network is somehow hard-coded on each branch (mainnet,alphanet,zeronet) as each network comes with its specific constants and a genesis block (which basically defines the network identifier). The config.json file aims to configure the behavior of a node (rpc port, number of connections, ...


1

There are no configuration options which can be done "live". All config changes require a node restart.


1

Their is currently no way to set a trusted peer by its ID in the node configuration file. If your peer has been set trusted through RPC and that your node was shutdown properly, the information is stored in the peers.json file and should be restored on node reboot, but I wouldn't rely on that.


Only top voted, non community-wiki answers of a minimum length are eligible