Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [compile]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
5 votes
1 answer
57 views

How does the 003-node binary download/compile/merge proposal code?

This question is in relation to the upcoming 004 (aka Athens) protocol change. Provided that it passes the last Promotion_vote phase, specifically and technically, what happens to the binaries on my ...
utdrmac's user avatar
  • 3,422
2 votes
1 answer
59 views

archetype: how to remove the bytes that are prepended by the pack() routine

I am trying to concatenate two strings and then convert to bytes using pack(). However this prepends some bytes to the front of the result. var str1 : string = "TEST INDEX #"; var str2 = ...
TomCollins's user avatar
1 vote
2 answers
100 views

Windows Subsystem for Linux 2 - Ubuntu 20.04 LTS - Does it work with Tezos?

I tried with Ubuntu 18.04 on WSL 1 and it did not work, it was not possible to build from source. Has anybody tried compiling on WSL2?
Babell's user avatar
  • 500
1 vote
2 answers
121 views

How to Integrating SmartPy compiler within the browser?

I have been trying to integrate the SmartPy compiler toolchain within Cryptoverse wars Learning interface and have been going through this video (OCaml Under The Hood: SmartPy) and have encountered ...
bhaskar kumar's user avatar
1 vote
2 answers
44 views

Truffle is not working for compiling and deploying

Is anybody here still using Truffle in order to compile and deploy Tezos projects? I created a project with it over a year ago and wanted to update the environment. After dowloading the latest Ligo ...
user avatar
1 vote
1 answer
47 views

Tezos compiling storage using file

The Tezos documentation all show the storage expression being defined inline when compiling storage. For example, using cameligo: ligo compile storage src/counter.mligo 5 --entry-point main If I try ...
codethink's user avatar
1 vote
1 answer
38 views

ocamlgraph.1.8.8: curl error code 403

I'm trying to install a server and getting an error when running make build-deps [ERROR] The sources of the following couldn't be obtained, aborting: - ocamlgraph.1.8.8: curl error code 403 ...
Warrick FitzGerald's user avatar
1 vote
1 answer
55 views

Send tez to an address, not a contract?

I have created a payment function, the problem is that the tez is debited from my contract and I would like it to be debited from a wallet address, how do I do this? If I replace Tezos.transaction ...
oriana's user avatar
  • 119
1 vote
0 answers
39 views

Deployment of a smart contract through fi compiler

I seem to fill in these parameters incorrectly. What do I need to enter in the Storage.Value and Storage.StartTime columns? If you can give examples
Chmoshk's user avatar
  • 125
0 votes
2 answers
128 views

Tezos Contracts Compiling Error

I am just days into learning how to build a dapp on Tezos for my thesis. I tried replicating the steps from Claude's tutorial - https://hackernoon.com/build-your-first-dapp-on-tezos-rwgl3ymb I ran ...
Weoy Howe Ang's user avatar
0 votes
0 answers
35 views

How can I give the right permissions to install tezos-rust-libs on Mac?

Am experiencing this error: # All required OS packages found. The following actions will be performed: ∗ install tezos-rust-libs 1.1 ∗ install bls12-381-unix 0.4.3 ===== ∗ 2 ===== <><&...
leo's user avatar
  • 165