5

I'm trying to activate an account on alphanet using a public node. I can't do it via my local node because I run into this problem, which is probably related to this.

So I decided to use a public node that is bootstrapped, like this:

./tezos-client -p PsddFKi32cMJ -A alphanet-node.tzscan.io -P 80 activate account testIdent with scripts/tz1cXy7wuoVoabWgG5kVxG25WdMttKyVv1yr.json -f

However this hangs on

Node is bootstrapped, ready for injecting operations.

For a long time (about half an hour) and then fails with

Error:
  Rpc request failed:
     - meth: POST
     - uri: http://alphanet-node.tzscan.io:80/chains/main/blocks/head/helpers/preapply/operations
     - error: Unexpected error 502:
                "<!DOCTYPE html PUBLIC \"-//W3C//DTD HTML 4.01//EN\" \"http://www.w3.org/TR/html4/strict.dtd\">\n<html>\n\t<head>\n\t\t<meta http-equiv=\"Content-Type\" content=\"text/html; charset=utf-8\">\n\t\t<title>ERROR: The requested URL could not be retrieved</title>\n\t\t<style type-\"text/css\">\n\t\t\t* {\n\t\t\t\tfont-family: verdana, sans-serif;\n\t\t\t}\n\t\t\tbody {\n\t\t\t\tmargin: 15px;\n\t\t\t}\n\t\t\t#content {\n\t\t\t\tfont-size: 12px;\n\t\t\t}\n\t\t\th1, h2 {\n\t\t\t\tmargin: 5px;\n\t\t\t}\n\t\t\th1 {\n\t\t\t\tfont-size: 21px;\n\t\t\t}\n\t\t\th2 {\n\t\t\t\tfont-size: 18px;\n\t\t\t}\n\t\t</style>\n\t</head>\n\t<body>\n\t\t<div id=\"title\">\n\t\t\t<h1>Error</h1>\n\t\t\t<h2>The requested URL could not be retrieved</h2>\n\t\t</div>\n\t\t<hr>\n\t\t<div id=\"content\">\n\t\t\t<strong>Error: There was an error when connecting to the website</strong>\n\t\t\t<p><strong>Why you are seeing this:</strong><br>\n\t\t\tYou are seeing this error because the web filter could not complete the request.\n\t\t\t</p>\n\t\t\t<p><strong>Possible reasons could be:</strong><br>\n\t\t\t<ul>\n\t\t\t\t<li>The web server is overloaded. Please try again later.</li>\n\t\t\t\t<li>There might be a problem with cookies. Please ensure your browser is enabled\n\t\t\t\tto store cookies for this site, clear your browser cache and try again.</li>\n\t\t\t</ul>\n\t\t\t</p>\n\t\t\t<p><strong>If this problem persists, please ask your administrator to:</strong><br>\n\t\t\t<ul>\n\t\t\t\t<li>Check the site is working - the website may be overloaded.</li>\n\t\t\t\t<li>Change how your browser handles 3rd party cookies.  Your administrator may\n\t\t\t\tneed you to clear your cache and disable caching of 3rd party cookies.</li>\n\t\t\t</ul>\n\t\t\t</p>\n\t\t</div>\n\t\t<hr>\n\t</body>\n</html> \n"
1
  • A 502 is a "Bad Gateway" error which means the front facing gateway got a bad response from it's backend (the node probably). Perhaps it's also getting the same error as your are seeing on your node? – asbjornenge Mar 27 '19 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.