I've tried to compile a Tezos Node on a Windows 10 PC with WSL Ubuntu.

I've used this Guide.

If i try to do make build-deps, i am getting the following error: Link

  • The error says Curl failed - do you have the curl command available on WSL? Mar 21, 2019 at 13:17
  • Hi, yeah: curl is already the newest version (7.58.0-2ubuntu3.2). Mar 21, 2019 at 14:13
  • eval $(opam env) opam update && opam upgrade Didn't help either. Mar 21, 2019 at 15:08

2 Answers 2


I seem to recall similar curl errors when building on older versions of ubuntu and debian. The solution there was to install a newer version of git. Look for references to "git" in https://github.com/tezoscommunity/FAQ/blob/master/Compile_Mainnet.md


I tried getting Tezos building and running on different WSL's but there was always different issues coming up - building Tezos was fine but running Tezos was tricky.

You can install VirtualBox (which is free) and then install a official Linux distribution.

It will be emulated so it is slower but it works perfectly.

You can copy & paste txt between host (Windows 10) and guest machine (Linux) and it even supports file drag & drop. Both of these features are life savers for development.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.