6

Contract (simple.liq):

[%%version 1.0]

type storage = int

let%init storage = 0

let%entry main (parameter : int) storage =
  ( [], storage + parameter )

Deployment command:

liquidity --tezos-node http://alphanet-node.tzscan.io:80 --private-key <key> --protocol alphanet simple.liq --deploy

After I run this command I get the following error that I cannot make sense of:

Response Error:
in /chains/main/blocks/head/helpers/preapply/operations
- branch: proto.003-PsddFKi3.implicit.empty_implicit_contract

It seems that the node thinks that our implicit contract is empty.

  • 1
    Looks like it's trying to use a mainnet node: proto.003-PsddFKi3 This refers to the proto 003 protocol that the mainnet runs, not the protocol for alphanet (which is PsddFKi32cMJ2qPjf43Qv5GDWLDPZb3T3bF6fLKiF5HtvHNU7aP) – Stephen Andrews Mar 21 '19 at 10:45
  • @StephenAndrews perhaps this is a valid answer ? – Ezy Mar 21 '19 at 10:48
  • @StephenAndrews I use the --protocol alphanet option, if that does not result in using the alphanet, then how should I do that? – Jan-Jaap Korpershoek Mar 21 '19 at 10:50
  • 2
    I don't know, I don't use liquidity - I'm just making an observation that the error being reported is from the mainnet protocol. @Ezy I don't think it's a valid answer, just a comment/observation - someone with experience with Liquidity should be able to answer. – Stephen Andrews Mar 21 '19 at 11:04
2

You are using a private key which do not correspond to any account on the alphanet. It works with

liquidity --tezos-node http://alphanet-node.tzscan.io:80 --private-key edsk2j7Ka5nRzh2QkGCtcD1dFLbHYvYw7XAafWL3YEAQQ3Zd61NiqS --protocol alphanet simple.liq --deploy
Main contract Simple
New contract KT18bLbXyH5yMY9ShDfCwtiXegWHMTa4aS8H deployed in operation opENiYZ3xMTDu1hVdLi7kSU3cybucZrDnAUXznMgCr2twecAu9S

You can also deploy on the alphanet with http://www.liquidity-lang.org/edit/ which allows you to see the balance on your account and interact with deployed smart contract.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.