I got a problem while running "activate account" with alphanet on docker (see image below). How do I fix it?

enter image description here


2 Answers 2


General remarks: raw text snapshots are more convenient for developers than pictures because you can quote them :-)

It looks like tezos-client does not understand the "uri" format file:/[...]. It's an annoying bug which is worth reporting at https://gitlab.com/tezos/tezos/issues .

I don't know if docker keeps the files it puts in /tmp/ or if it erases them immediately. If files stay for a bit, now that the son file is in the container, alphabet.sh client activate account peach with /tmp/tz1....json should work...

  • 1
    and Now I can run tezos-client finish but I can't activate account success , How do I fixed it ? ... Fatal error: The operation opAguJg1GCLJUQ1qShiQDAcC56Zv41nZJcaePz8mGj21CSnfEKe is outdated and may never be included in the chain. We recommand to use an external block explorer. Commented Mar 22, 2019 at 7:36
  • I am also getting the same error when I run "./alphanet.sh client activate account user_1 with tz1xxx...xxxxxubq.json" When json file is in the same folder of alphanet.sh script. Error thrown was: Erroneous command line argument 5 (tz1xxx...xxxxxubq.json). File doesn't exist: 'tz1xxx...xxxxxubq.json' How did you solve it?
    – user_184
    Commented Mar 31, 2019 at 15:15
  • Also, I made the local set up via "Build from Sources" option and was getting the outdated error you mentioned in the comment. HOw did you resolved that?
    – user_184
    Commented Mar 31, 2019 at 15:28

Okay so this is my first stackexchange answer ever and I'm surprised I was the one to figure this out but here's what I did after several hours.

The problem is that docker cannot access the place in your filesystem that has your temp wallet in it. So I found this article detailing how to mount a volume to a docker container while it is running: https://jpetazzo.github.io/2015/01/13/docker-mount-dynamic-volumes/

You need to find the name of your tezos node with

docker ps

(1) Mine is called


(2) Next you need to find the location of your .json file. Mine is in


(3) Next enter your container with >./alphanet.sh shell then create the directory in the container you want to contain the .json file. Mine is


Use those three values for the variables at the top of the script in the linked article at the top:


Also make sure you download the nsenter script from the linked article using

docker run --rm -v /usr/local/bin:/target jpetazzo/nsenter

Finally I had to change some of the syntax at the bottom of the script in the article, deleting the -- in the bottom rows and changing --mode to -m for mknod. Hope this helps!

  • heroic! answering a question back from march, welcome to TSE!
    – Ezy
    Commented Jun 23, 2019 at 3:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.