3

Does anyone know, if this error means that is a bad block? or that i'm doing something wrong?

The error happens when I try to Inject a Block.

[{"kind":"permanent","id":"validator.invalid_block","invalid_block":"BL6u6y3xWjw35nNTL7g6ayW8npVz1KHbZc3SwCguRiW9ghf9rPL","error":"cannot_parse_bock_header"}]

Cannot find this error at http://tezos.gitlab.io/mainnet/api/errors.html

  • Can you please provide more details on what you are doing ? How did you forge this block etc – Ezy Mar 21 at 9:15
  • I think the problem was because I was creating an invalid protocol_data on shell_header and then sending it to /chains/main/blocks/head/helpers/forge_block_header. Should be fixed now. – RoMarQ Mar 21 at 9:46
  • glad you solved your problem. Would you mind posting your solution as a full answer so we know the problem is resolved ? We keep track of open questions so making sure the problem is solved is important. Thanks – Ezy Mar 21 at 10:41
0

Problem Solved!

The issue was because of an invalid proof of work nonce that I was creating and it failed when I tried to inject the block.

I was inserting non hexadecimal characters in the header.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.