4

I get this error message when compiling binaries.

Error: Library "tls" not found.
Hint: try: dune external-lib-deps --missing src/bin_node/main.exe src/bin_client/main_client.exe src/bin_client/main_admin.exe src/bin_signer/main_signer.exe src/lib_protocol_compiler/main_native.exe src/proto_003_PsddFKi3/bin_baker/main_baker_003_PsddFKi3.exe src/proto_003_PsddFKi3/bin_endorser/main_endorser_003_PsddFKi3.exe src/proto_003_PsddFKi3/bin_accuser/main_accuser_003_PsddFKi3.exe
make: *** [all] Error 1

I am Running High Sierra 10.13.6, and following instructions from Corey Soreff....mainnet. I ran Make build-does before running make. Now command not found when trying sudo apt-get update

Any ideas what's wrong?

  • Welcome to Tezos! Could you please specify your platform ? the branch you checked out ? which instructions you are following ? did you run make build-deps before running make ? – Ezy Mar 21 at 1:00
  • I am Running High Sierra 10.13.6...following instructions from Corey Soreff....mainnet, I ran Make build-does before running make....now command not found when trying sudo apt-get update – Adi_daz Mar 21 at 1:09
  • Did you try following the hint ? – Ezy Mar 21 at 1:14
  • I am a newbie and did not understand how to – Adi_daz Mar 21 at 1:19
  • 1
    I had to install the pkg via brew – Adi_daz Mar 21 at 2:09
1

It seems that the error message is giving you instructions on how to install the missing dependencies. Just follow the hints and install what is requested.

In your case your error message was telling you to try:

dune external-lib-deps

and on a Mac with brew can try:

brew install external-lib-deps

It is common to have several such missing dependencies that will give these errors and each one will need to be installed.

  • @luchonacho edited with the hint that your error message was inviting the user to try – Ezy Mar 21 at 9:11
  • @luchonacho fyi on TSE if the answer is fully satisfying, it is custom (and important for TSE) that you accept it by clicking on the “checkmark” icon next to the best answer. – Ezy Mar 21 at 9:12
  • Indeed (being using TSE for 8 years now :) ). Notice I'm not the OP. I did not ask the question. – luchonacho Mar 21 at 9:20
  • @luchonacho aha i did not realize TSE was that old! I thought it came to life 43 days ago ;) yea sorry initially i thought OP was commenting :) – Ezy Mar 21 at 9:33
  • 1
    Oh, I though by TSE you meant "the stack echange [network]", and not Tezos SE. hehe. All confusion around here. – luchonacho Mar 21 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.