3

I am having a little bit of trouble with my node and would appreciate some help.

I have been baking flawlessly on my old macbook pro running ubuntu many months, but since there was one miss last week, I decided check what was happening. Effectively, virtualbox did not respond and I had to restart ubuntu. Still, I had my last verification yesterday, so things could not be too bad.

I run, as usual, nohup ./tezos-node run --rpc-addr 127.0.0.1:8732 & to get the node back online, but I am nothing is happening for almost an hour, that is, ./tezos-client bootstrapped tells me that it cannot connect to the node. In fact, it gives me the following output:

"Warning: failed to acquire the protocol version from the node" and "Error: Rpc request failed". 

The reason seems to be in both cases:

"Unable to connect to the node: connection refused" 

I also checked the system reports, tezos-node is up and running but only consume 2% CPU, so it looks dead to me. Internet is working (Ethernet connection), I am logging into the computer via TeamViewer right now. Finally, I have been checking the lock.mdb and data.mdb files. The lock.mdb file was generated when I restarted the node, but the data.mdb file is not updating, which suggests to me again that I am having connection issues.

I could try restarting, but my guess is that I would only end up in the same spot again. Maybe I should try to manually connect to some nodes, but I am not sure about that and which to choose in case. Finally, maybe I am just not understanding the situation at all.

  • Have you tried to do a: cd tezos && git checkout mainnet && git pull && make build-deps && eval $(opam env) && make clean && make And tried it again? – Blindripper Mar 20 at 11:02
  • This sounds like rebuilding to me, which should not be necessary. But it is certainly an option if I fail. At the moment, I am hesitant to do it though. – undergroundsea Mar 20 at 12:37
4

You need to supply an initial list of peers for bootstrapping. Use the following parameter to supply one or more peers when starting the node:

./tezos-node config update --peer=IPADDR:PORT --peer=...

You can find a list on tzscan or use at least --peer=boot.tzbeta.net

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.