4

I have set up my tezos services to be controlled by systemd using etomknudsen's scripts. The output from those services gets logged by journald with double timestamps since both the tezos applications and journald itself each add a timestamp. For tezos-node a typical log line looks like this:

Mar 18 08:44:58 baker.example.com tezos-node[27442]: Mar 18 08:44:58 - validator.chain(1): Pushed: 2019-03-18T13:44:58Z, Treated: 2019-03-18T13:44:58Z, Completed: 2019-03-18T13:44:58Z

Can I change the configuration so that only one timestamp appears in each log line?

1 Answer 1

2

For the tezos-node service it is possible to remove the timestamp using a tezos-node configuration with the following additional parameter at the top level:

 "log": { "template": "$(section): $(message)" },

That results in log output like this:

Mar 18 09:41:43 baker.example.com tezos-node[27537]: validator.chain(1): Pushed: 2019-03-18T14:41:43Z, Treated: 2019-03-18T14:41:43Z, Completed: 2019-03-18T14:41:43Z

Edit: As of octez v18.0, the above does not work, resulting instead in a fatal error about "Invalid configuration file: Unexpected object field template"

2
  • 1
    I have not found a similar solution for tezos-baker and tezos-endorser. Any ideas? Mar 18, 2019 at 14:44
  • Interesting. Code here and here suggest that the client would need a patch to accept a template (from config file? env var?). As a hack, one could just patch here...
    – Tom
    Mar 18, 2019 at 15:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.