7

I'm setting up a Linux Tezos baking node with Ledger Nano S. The node is running and synced, but list connected ledgers will not show that the Ledger is connected.

Both the wallet and baking apps are installed from Ledger Live. The firmware on the Nano S is the newest.

Linux shows the USB with lsusb, and dmesg shows all the details of the Ledger, but list connected ledgers finds no Nano S.

I have modified my udev rules to include the correct group for my user account.

But the Tezos client still doesn't detect the Ledger Nano S.

  • Are you running either the wallet or baker app on the ledger when you try to connect (asking because you don't specify this, only that you have both apps installed). – Stephen Andrews Mar 5 '19 at 4:47
  • 2
    Perhaps you could share the contents of /etc/udev/rules.d/20-hw1.rules and the output of the id command so we can have a look. – Fred Yankowski Mar 5 '19 at 15:35
  • Please show the output of ls -la /dev/bus/usb/*/* and also provide the username you try to connect with and the groups of this user. – Phlogi Jan 23 at 20:23
0

Running tezos-client list connected ledgers as root connects to the ledger in order to import private key. But, still cannot find it under user.

  • Same situation. list connected ledgers only works when running tezos-client as root. What's the fix to allow regular user to see ledger? – utdrmac Feb 24 at 18:14
0

Found a solution that worked for me. "Option 1" on this Ledger Support Page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.