7

I used below command to start my private node:

./mainnet.sh start --private-mode --no-bootstrap-peers --bootstrap-threshold=1 --connections 1 --peer=`public_node_ip`:9732

My public_node is already running with connections to its peers.

Now my private node logs just shows "incoming connection rejected due to untrusted source" and my private node just does not connect to the public node.

I even checked the config.json file, my public_node_ip was there against "bootstrapped-peers" key.

What else I should do to connect my private node to my public node?

2
  • could you run your private node with --rpc-addr=localhost and give the output of running (on the same machine as your private node) tezos-client rpc get /network/points/public_node_ip:9732 ? – Julien Mar 8 '19 at 10:08
  • I have setup a new machine and started my node in private mode right from starting (never started my node in public mode) now it is able to connect to my public node mentioned in --peer option. – Sachin Tomar Mar 14 '19 at 7:02
1

The incoming connection rejected due to untrusted source is most certainly due to a previous non-private run on the same IP. Your IP is known as a potential peer, so other nodes try to connect. It is not a problem, your node will simply reject these connections.

Maybe your public node was saturated. It is important that your public node also has your private node in its trusted peers. So your public node should also be run with --peer=private_node_ip:port or with your private node IP in the config.json file.

It is very important that the public node consider the private node as trusted. If not, the private node might be kicked during connections maintenance phase.

1
  • I had added the private-node ip to public-node trusted ip addresses. It could be the case my public-node was already full with the connections that it could not connect with my private node. – Sachin Tomar Mar 19 '19 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.