I am trying to develop an NFT based on the FA2 standard, but as of now, it is recognized as a Token and not as a NFT inside the balance tab: https://ghostnet.tzkt.io/KT1Q2FhhCmYq6X1mF6w831EEJnpm6miYnbZH/operations/

Is there a part of the specification / token_metadata to change in order to make it show up correctly ?

Thanks in advance,

1 Answer 1


You store token metadata in a non-standard format, so generic indexers, like TzKT, just cannot parse it (you can see that your metadata wasn't recognized: ghostnet.tzkt.io/KT1..nbZH/tokens/0/metadata).

According to TZIP-12, token metadata must be stored in the following format:

Store the values in a big-map annotated %token_metadata of type (big_map nat (pair (nat %token_id) (map %token_info string bytes)))

This will enable indexers to properly parse the metadata.

So, this is how your token metadata looks, and this is how it should look according to the standard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.