0

I'm trying to run through this tutorial on DApp development with Ligo (https://tezos.com/developers/tutorials/nft-ligo-marketplace/) and am running into an error.

TAQ_LIGO_IMAGE=ligolang/ligo:0.73.0 taq ligo --command "install @ligo/fa"

gives me the following error:

enter image description here

1
  • 1
    FYI : esy dependency will be remove in few weeks Commented Sep 22, 2023 at 11:52

2 Answers 2

2

I cannot reproduce it locally so it's hard to find the solution.

FYI You are using docker, esy is directly installed inside so you should not have to install esy before.

Some clues :

When you run this command, the command behind should be :

docker run --rm -v "$PWD":"$PWD" -w "$PWD" ligolang/ligo:0.73.0 install @ligo/fa

Can you try it to verify it's not related to taqueria ?

Maybe you should verify what is inside your image by running :

docker run -it --entrypoint=/bin/bash ligolang/ligo:0.73.0

Maybe you can also try to check the shasum :

docker inspect --format='{{index .RepoDigests 0}}' ligolang/ligo:0.73.0
ligolang/ligo@sha256:6d9839ba3ca6190fb6d8cf39f76c618ed54af924a5c9187deea68a7e10b087b8
7
  • 1. clue --> error: No solution found: No package matching: blindripper -> vite-compatible-readable-stream@^3.6.1 resolving request vite-compatible-readable-stream@^3.6.1 esy: exiting due to errors above error while install packages 2. --> looks good; image is loaded and files look ok. 3. --> SHA same as yours 6d9839ba3ca6190fb6d8cf39f76c618ed54af924a5c9187deea68a7e10b087b8 Commented Sep 22, 2023 at 14:20
  • Are you usign a package.json file or a esy.json file ? Commented Sep 22, 2023 at 15:22
  • Looks like you have a package.json, If you are on taq, probably you are building a dApp, and so you have to use a esy.json (it'll be not the case in ligo 1.0.0 only a ligo.json will be accepted ) To intialize it you have to create esy.json file containing {} Commented Sep 22, 2023 at 15:24
  • I did create an esy.json file (just like the mentioned tutorial said). Commented Sep 22, 2023 at 16:30
  • Weird, esy try to install your package.json here.. Any chance to have access to your code somewhere to see if the issue come from your local or the project itself ? Commented Sep 22, 2023 at 19:20
0

You need to install esy using npm install -g esy, more info can be found here: https://esy.sh/

1
  • Same error as before. Commented Sep 22, 2023 at 12:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.