7

I recently updated my mainnet.sh script as it says the script present is not the latest image. I am following exact steps as mentioned here.

And when my turn for endorsement came, I missed it with the below error in endorsement logs when transaction was sent to remote-signer signed using authentication key.

Error: Unregistred error: { "kind": "generic", "error": "invalid authentication signature" }

It was working before the script updation. Was something updated in my mainnet.sh script regarding remote signer authentication keys?

  • you should precise what script version you used to run and what script version you run now – Ezy Mar 3 '19 at 21:35
1

If you use tezos-signer remotely, and set the option to require authentication, then you probably updated the node to the latest mainnet but you did not update the remote signer code, be sure it is updated. Sometimes it is not required, but the voting update seem to have changed something in authentication between remote signer and endorser/baker. I did encounter this and resolved it that way. hope it helps anyone else that encounter it.

| improve this answer | |
  • Yes i did not update the remote-signer. I'll try that and let you know. It was simple to update the mainnet.sh script file but what is the process to update the remote-signer binary? – Sachin Tomar Mar 17 '19 at 7:05
  • from the terminal got to your tezos directory and run this: git checkout mainnet && git pull && make build-deps && eval $(opam env) && make That should do it. – Zx1984 Mar 19 '19 at 14:25
  • Thanks. Will share the update here. – Sachin Tomar Mar 20 '19 at 14:26
1

I had the exact same error. My install is not the Docker-images but the classic install documented here: https://github.com/tezoscommunity/FAQ/blob/master/Compile_Mainnet.md

My issue turned out to be that I run the tezos-signer via Screen, and the Screen session (not just the tezos-signer program inside it) needs to be restarted to see the new tezos-signer binary after update. This fixed the problem for me.

So in short: Maker sure you are using the same version tezos-node, tezos-baker, tezos-signer, etc.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.