5

Is there a way to build a full node on a Windows system (not a docker build)?

If not, is there a particular reason why the platform is not supported? 

3
  • 1
    Probably because OCaml (the language of Tezos code) is not supported well on Windows: ocaml.org/docs/install.html#Windows
    – utdrmac
    Feb 25 '19 at 15:02
  • 1
    @utdrmac thanks! Will give a look. I am curious if someone ever have it a try.
    – Ezy
    Feb 25 '19 at 15:03
  • Windows OS is not stable, recommended like-Linux OS. Aug 27 '20 at 19:59
2

Linux is a much more secure platform than Windows. You can use it to build a node, but I recommend building a node on Linux

1
  • 3
    Bitcoin needs as much security as tezos well but there is a windows node. I don’t believe absence of the windows node is a consequence of the team rejecting windows as « unsafe ».
    – Ezy
    Feb 27 '19 at 12:42
1

Well, one workaround would be to use the Windows Subsystem for Linux. But really, using docker is so, so much easier.

5
  • 1
    Not for baking i believe ?
    – Ezy
    Feb 25 '19 at 8:08
  • @Ezy why not for baking? I use it for baking, works fine! 😄👍 Feb 27 '19 at 12:41
  • @asbjornenge did you manage to apply the ledger udev rules and connect it?
    – jdsika
    Aug 27 '20 at 15:49
  • @jdsika well yes, I'm currently baking & using remote signer using docker. But if I remember correctly the issue wasn't the udev rules but some permissions issue - need to run the signer container as privileged and as the root user inside the container or something like that 😅👍 It's been a while since I set it up 😝 Aug 31 '20 at 7:18
  • You would do me a tremendous favor if you would edit my answer here and extend it with the ledger instructions!
    – jdsika
    Aug 31 '20 at 8:18
1

I am using the Windows subsystem and I wanted to write an answer but apparently someone wrote exactly what I had in mind :) I am using Ubuntu 20.04 on Windows 10 from the Windows Store:

Enable Ubunut on Windows as described here

Note: WSL is available since Windows 10 version 2004

Go and see here for troubleshooting if you already tried to init opam

I am using this on a fresh installation:

sh <(curl -sL https://raw.githubusercontent.com/ocaml/opam/master/shell/install.sh)
opam init --disable-sandboxing
opam switch create for_tezos 4.09.1

The installation of the Tezos binaries through opam worked great:

opam install depext
opam depext tezos
opam install tezos

And update it:

opam update
opam depext
opam upgrade
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.