4

I had the node fully synced just a couple of days ago and had to restart several times while working on things. Now it wont start syncing and keeps throwing these same errors - any ideas on how to fix?

Of course I don't wanna delete 80+ Gb context + data chain! Running in docker container installed from tezos mainnet.sh. Box has 20gb free ram, cpu and enough disk. Running on latest protocol 003-PsddFKi3

Feb 21 00:44:11 - validator.peer(276): Worker started for NetXdQprcVkpa:idsjspFRxYWD
Feb 21 00:44:11 - node.validator.bootstrap_pipeline: Unexpected error (validator):
Feb 21 00:44:11 - node.validator.bootstrap_pipeline: Error, dumping error stack:
Feb 21 00:44:11 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:11 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:11 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:11 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:11 - node.validator.bootstrap_pipeline:
Feb 21 00:44:11 - validator.peer(276): Worker crashed:
Feb 21 00:44:11 - validator.peer(276): Not_found
Feb 21 00:44:11 - validator.peer(276): Not_found
Feb 21 00:44:11 - validator.peer(276): Not_found
Feb 21 00:44:11 - validator.peer(276): Not_found
Feb 21 00:44:15 - validator.peer(277): Worker started for NetXdQprcVkpa:idsn9he7cC2z
Feb 21 00:44:15 - node.validator.bootstrap_pipeline: Unexpected error (validator):
Feb 21 00:44:15 - node.validator.bootstrap_pipeline: Error, dumping error stack:
Feb 21 00:44:15 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:15 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:15 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:15 - node.validator.bootstrap_pipeline:   Not_found
Feb 21 00:44:15 - node.validator.bootstrap_pipeline:
Feb 21 00:44:15 - validator.peer(277): Worker crashed:
Feb 21 00:44:15 - validator.peer(277): Not_found
Feb 21 00:44:15 - validator.peer(277): Not_found
Feb 21 00:44:15 - validator.peer(277): Not_found
Feb 21 00:44:15 - validator.peer(277): Not_found
Feb 21 00:44:17 - node.main: Received the TERM signal, triggering shutdown.
Feb 21 00:44:17 - node.main: Shutting down the Tezos node...
Feb 21 00:44:17 - validator.chain(1): Worker terminated
Feb 21 00:44:17 - validator.block: Worker terminated
Feb 21 00:44:17 - prevalidator.NetXdQprcVkpa.PsddFKi32cMJ(1): Worker terminated
Feb 21 00:44:17 - node.main: Shutting down the RPC server...
Feb 21 00:44:17 - node.main: BYE (-11)
3
  • What is your platform ? Which is the commit hash of your build ? Did you move the context folder ? Is your disk full ? Are you using a docker ? Give more context pls otherwise it is hard to help you – Ezy Feb 21 '19 at 3:36
  • it running in docker on alipine .. i didnt build used the mainent.sh on tezos tech doc site as i said it was synced and running fine. Install everything with docker-compose ..no i didn't move context folder..disk has plenty of space running on latest protocol 003-PsddFKi3 – kahmed Feb 21 '19 at 3:47
  • Update your question to give context pls instead of responding in the comments. Better to improve your question to make it as clear as possible pls – Ezy Feb 21 '19 at 3:48
4

It looks like an inconsistency in the database. Once a block has been validated by the node and stored in the store database, its context is supposed to be stored in the context database. It looks like the error messages say that the node cannot find the context of a block. It's probably because the two databases are not synchronized anymore, probably the store database has blocks that the context does not have.

You should remove the store database, it will restart synchronizing from the beginning. For more security, you might also remove the context database, in case there are more errors inside.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.