2

I apologise in advance if the question I am trying to ask is trivial and not very interesting.

I have just started to get interested in the tezos blockchain and its tools and I am encountering an error that I cannot solve.

To start with my computer is a macbook pro M1 2020.

The problem comes from the quickstart documentation: https://taqueria.io/docs/getting-started/quickstart/

when I get to the step where I have to use the following command

taq originate counter.tz

I get a response: Error while performing operation:

HttpRequestFailed: GET http://localhost:20000/chains/main/blocks/head/context/contracts/tz1aSkwEot3L2kmUvcoxzjMomb9mvBNuzFK6/manager_key Error: socket hang up {
  "name": "HttpRequestFailed"
}
No operations performed

Do you have any idea how to solve this problem?

Thank you in advance for your time and expertise

Theo

3
  • Are you running a Flextesa sandbox? The URL localhost:20000 is typically a Flextesa sandbox blockchain Feb 28, 2023 at 10:17
  • That's correct, and you can see from the error message that it's not a 404 error. I believe it's something else, but I'm not sure what. When I tested it with Postman, I received a 200 response, indicating that everything is working correctly.
    – ThéoS
    Mar 1, 2023 at 11:30
  • when I make this request : "localhost:20000/chains/main/blocks/head/context/contracts/…" I get this answer "edpkurPsQ8eUApnLUJ9ZPDvu98E8VNj4KtJa1aZr16Cr5ow5VHKnz4" I think the problem is with taq cli or maybe directly with my computer, I don't really know.
    – ThéoS
    Mar 2, 2023 at 5:27

3 Answers 3

2

I faced the exact same error going through taqueria Quickstart guide.

Just like you, I used node 19 version, but on Linux. I saw the issue that you created and noticed that reinstalling the node helped you. I installed nvm in order to be able to switch to the v16 node and I then I succeed to run the taq originate counter.tz command.

I'm leaving this answer for anyone else who runs into this problem:

  1. In order to install nvm, you can follow the instructions on nvm repository.
  2. Then you will need to install the 16th node using the nvm install 16 command
  3. After that, you probably need to restart your bash and then you will be able to the taq originate counter.tz command. In my case it ran without any problems and resulted in the same way as it was expected in tutorial
0

Where are you trying to originate the contract?

  • locally, you will need to run a flextesa sandbox.
  • ghostnet/testnet, you can use the --env parameter for the taq originate.
  • mainnet, same as for ghostnet, you can provide an environment using the --env parameter.

For more details on how to use/set up an environment, you can check the taqueria config.json here.

5
  • I do it with a local node. I do use flextesa sandbox. I follow the tutorial exactly to be honest but I can't do taq originate counter.tz by the way all the previous steps work
    – ThéoS
    Feb 28, 2023 at 14:41
  • the following command taq list accounts local gives me what is expected
    – ThéoS
    Feb 28, 2023 at 14:48
  • Are you sure that flextesa sandbox is running on port 20000? If you are running on linux, you can check that using sudo netstat -tulpn | grep 20000
    – Florin
    Feb 28, 2023 at 14:54
  • I'm on macos. And yes I'm sure that the flextesa sandbox is running on the port 20000 because i've send a request with postman and I double check with docker.
    – ThéoS
    Mar 1, 2023 at 2:59
  • when I make this request : "localhost:20000/chains/main/blocks/head/context/contracts/…" I get this answer "edpkurPsQ8eUApnLUJ9ZPDvu98E8VNj4KtJa1aZr16Cr5ow5VHKnz4" I think the problem is with taq cli or maybe directly with my computer, I don't really know.
    – ThéoS
    Mar 2, 2023 at 5:27
0

Please ensure that your sandbox has been started by running docker ps - you should see output that includes oxheadalpha/flextesa in the output:

b20f0d4bc388   oxheadalpha/flextesa:20221123                 "/bin/sh"                6 seconds ago   Up 6 seconds   0.0.0.0:20002->20000/tcp   taq-flextesa-local-4535c

If you don't find that in the output, then you'll need to start your sandbox by running taq start sandbox.

If you do have a sandbox up and running, sometimes you need to give the sandbox 10-30 seconds to fully boot before you can inject an operation. This is a known issue that we're working on: https://github.com/ecadlabs/taqueria/issues/1846

If you think that issue is what you're running into, then just retry running taq originate counter.tz again after giving the sandbox some time to start.

Please post back if you continue to have issues and I'll do my best to help you.

3
  • I give 2h to the docker image but nothing change i've got the same error...
    – ThéoS
    Mar 1, 2023 at 3:00
  • I'm wondering if the issue could be related to my Node.js version. I'm currently using version 19.4.0, whereas I noticed on GitHub that you're using an earlier version.
    – ThéoS
    Mar 1, 2023 at 11:50
  • when I make this request : "localhost:20000/chains/main/blocks/head/context/contracts/…" I get this answer "edpkurPsQ8eUApnLUJ9ZPDvu98E8VNj4KtJa1aZr16Cr5ow5VHKnz4" I think the problem is with taq cli or maybe directly with my computer, I don't really know.
    – ThéoS
    Mar 2, 2023 at 5:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.