0

I am trying to install the library tezos-crypto using Opam on Kubuntu 20.04. I am getting the following error:

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><><><>
[ERROR] The compilation of tezos-stdlib-unix failed at "/home/marc/.opam/opam-init/hooks/sandbox.sh build dune build -p
        tezos-stdlib-unix -j 15".

#=== ERROR while compiling tezos-stdlib-unix.10.2 =============================#
# context     2.0.5 | linux/x86_64 | ocaml-base-compiler.4.11.1 | https://opam.ocaml.org#e0171a79
# path        ~/.opam/default/.opam-switch/build/tezos-stdlib-unix.10.2
# command     ~/.opam/opam-init/hooks/sandbox.sh build dune build -p tezos-stdlib-unix -j 15
# exit-code   1
# env-file    ~/.opam/log/tezos-stdlib-unix-69301-e0ba4f.env
# output-file ~/.opam/log/tezos-stdlib-unix-69301-e0ba4f.out
### output ###
# [...]
# (cd _build/default && /home/marc/.opam/default/bin/ocamlc.opt -w -40 -open Tezos_error_monad -open Tezos_error_monad.TzLwtreslib -open Tezos_event_logging -open Tezos_stdlib -open Data_encoding -g -bin-annot -I src/lib_stdlib_unix/.tezos_stdlib_unix.objs/byte -I /home/marc/.opam/default/lib/angstrom -I /home/marc/.opam/default/lib/astring -I /home/marc/.opam/default/lib/base -I /home/marc/.op[...]
# File "src/lib_stdlib_unix/file_descriptor_sink.ml", line 116, characters 16-24:
# 116 |                 Fmt.strf "%s-%d%s" chopped (Unix.getpid ()) ext
#                       ^^^^^^^^
# Alert deprecated: Fmt.strf
# use Fmt.str instead.
# (cd _build/default && /home/marc/.opam/default/bin/ocamlopt.opt -w -40 -open Tezos_error_monad -open Tezos_error_monad.TzLwtreslib -open Tezos_event_logging -open Tezos_stdlib -open Data_encoding -g -I src/lib_stdlib_unix/.tezos_stdlib_unix.objs/byte -I src/lib_stdlib_unix/.tezos_stdlib_unix.objs/native -I /home/marc/.opam/default/lib/angstrom -I /home/marc/.opam/default/lib/astring -I /home/[...]
# File "src/lib_stdlib_unix/file_descriptor_sink.ml", line 116, characters 16-24:
# 116 |                 Fmt.strf "%s-%d%s" chopped (Unix.getpid ()) ext
#                       ^^^^^^^^
# Alert deprecated: Fmt.strf
# use Fmt.str instead.



<><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><>
┌─ The following actions failed
│ λ build tezos-stdlib-unix 10.2
└─ 
╶─ No changes have been performed

1 Answer 1

2

Because you are in an opam "switch" that uses an old version of the OCaml compiler (4.11.1), you are trying to install the most recent version of tezos-crypto compatible with this compiler which is an old version (10.2).(Probably, this version is not compatible with a version of the fmt library that has been released more recently than tezos-crypto.10.2 and no "upper bound" has been specified in the set of version constraints).

By using the current version of the OCaml compiler used by Octez (4.14.*), you should be able to install the latest version of tezos-crypto (15.1) which hopefully compiles fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.