0

I have deployed a contract with basic mint and transfer of NFT. I did some transaction on that contract like minting into one address and then transferring the token from one address to another address. You can checkout the storage of contract address here. https://better-call.dev/ghostnet/KT1ExoT6i2EnVBHMdVDrfDeNX7bUHdKjJYzH/storage

Since I have already done transfer of tokens and it did work fine. Now I need to change the policy to policy = FA2.NoTransfer() and disable the transfer of tokens between the address. I guess it is not possible to update the contract in tezos , so what can be done here to disable the transfer of that NFT contract? Any suggestion would be appreciated.

1 Answer 1

1

I'm guessing you've deployed the smartpy FA2 template.
I'm not very familiar with the template (in fact just now I went to have a look at it and discovered that they have a new template that I wasn't aware of).
They have a PauseTransfer policy, that seems to do exactly what you want, but this has to be declared at contract origination, so if you want to use it you'll need to redeploy the contract.
After you deploy the contract with the PauseTransfer policy and the Admin mixin, you'll have a set_pause entrypoint that you can use to disable transfers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.