Trying for the first time to run a mainnet baker on a vps, using a remote signer on a home laptop with Nano ledger. Node is synced. As soon as the baker tries to endorse, it throws the below error


    skipping preendorsement for baker (tz1*****************
Oct  5 04:59:02.520 - 014-PtKathma.baker.actions:   Error:
Oct  5 04:59:02.520 - 014-PtKathma.baker.actions:     Rpc request failed:
Oct  5 04:59:02.520 - 014-PtKathma.baker.actions:        - meth: GET
Oct  5 04:59:02.520 - 014-PtKathma.baker.actions:        - uri: http://aaa.bb.cc.ddd:xxxx/authorized_keys
Oct  5 04:59:02.520 - 014-PtKathma.baker.actions:        - error: Unable to connect to the node: "Unix.Unix_error(Unix.ECONNREFUSED, "connect", "")"

baker process is being run as tezos-baker-014-PtKathma --remote-signer http://aaa.bb.cc.ddd:xxxx -f /home/yyyyy/pwdfile run with local node /home/yyyyy/.tezos-node baker --liquidity-baking-toggle-vote pass and on the home laptop the signer is running as tezos-signer --base-dir /home/zzzzz/tezos-signer-remote --require-authentication launch http signer -a aaa.bb.cc.ddd -p xxxx Port xxxx on the home laptop is open in the firewall rules. Home laptop running Ubuntu 20.04 I'm sure I'm missing some import steps along the way, even though I was trying to follow https://tezos.gitlab.io/user/key-management.html. Or, I'm not running the remote signer with the wrong attributes. Any ideas where I should start looking?

EDIT: Tried redoing the key management steps, but slightly different On the home laptop:

tezos-signer --base-dir /home/yyyyy/tezos-signer-remote import secret key baker ledger://xxxxxxxx-yyyyyyy-zz-aaa/ed25519/0h/0h
nohup tezos-signer --base-dir /home/yyyyy/tezos-signer-remote --require-authentication launch http signer -a aaa.bb.cc.ddd -p xxxx &

On the vps: tezos-client import secret key baker http://aaa.bb.cc.ddd:xxxx/tz1*************************** but now getting this error

 Rpc request failed:
     - meth: GET
     - uri: http://aaa.bb.cc.ddd:xxxx/tz1***************************
TEZOS_MAINNET"Unable to connect to the node: "Failed to read response: Malformed response first line: <garbage characters>

2 Answers 2


You should run a node on the VPS (with home/yyyyy/.tezos-node as data-dir) and open its RPC port to localhost.

  • Node's running on the vps, tezos-node run --data-dir /home/yyyyy/.tezos-node --rpc-addr
    – Cardsfan
    Oct 5, 2022 at 23:53

After looking through How to run a baker with ledger (remote signer), I ended up setting up a tunnel between the vps and the home laptop using zerotier.com. That worked, although instead of the error showing up, the connection from the baker on the vps to remote signer seemed to hang. That was resolved by removing the --require-authentication option from the tezos-signer process

  • If you found a good solution to your own question it's OK for you to approve it as the answer.
    – ktorn
    Oct 7, 2022 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.