0

I'm trying to set up a new local node for Jakartanet using the docker setup, as I've done in the past for previous testnets. Unfortunately, no matter how I try to setup the node, it seems to fail to connect to it with the following error

./jakartanet.sh head
Warning:
  Failed to acquire the protocol version from the node
  Rpc request failed:
     - meth: GET
     - uri: http://node:8732/chains/main/blocks/head/protocols
     - error: Unable to connect to the node: "Unix.Unix_error(Unix.ECONNREFUSED, "connect", "")"

Error:
  Rpc request failed:
     - meth: GET
     - uri: http://node:8732/chains/main/blocks/head/header
     - error: Unable to connect to the node: "Unix.Unix_error(Unix.ECONNREFUSED, "connect", "")"

I've tried to run the node using just ./jakartanet.sh node start, or using ./jakartanet.sh node start --rpc-port 8732 --rpc-addr 0.0.0.0:8732 --allow-all-rpc 0.0.0.0:8732, and most combinations of only some of the parameters. When I'm trying to curl directly it also refused to connect

curl http://localhost:8732/version
curl: (56) Recv failure: Connection reset by peer

I'm currently not using a snapshot, but earlier I tried to do the same with a snapshot and had similar issues. Does anyone have any idea what I might be doing wrong?

1 Answer 1

1

That's a known bug. You can track it here: https://gitlab.com/tezos/tezos/-/issues/3280

edit: original issue https://gitlab.com/tezos/tezos/-/issues/2972

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.