0

I'm trying to run Jakarta testnet node locally. Node starts and syncs, but RPC does not work. docker-compose.yaml I'm using:

version: "2"
services:

  node:
    image: tezos/tezos:v13.0
    hostname: node
    command: tezos-node --network=jakartanet
    ports:
      - 9732:9732
    expose:
      - '8732'
    volumes:
      - node_data:/var/run/tezos/node
      - client_data:/var/run/tezos/client
    restart: on-failure

volumes:
  node_data:
  client_data:

What am I doing wrong here?

1 Answer 1

0

This should fix the issue if you are calling the RPC from the host.

ports:
  - 9732:9732
  - 8732:8732
volumes:
   ...
5
  • didn't help, any other ideas?
    – fr3ak
    Commented May 9, 2022 at 13:58
  • Did you remove 'expose'? Can you show the logs? docker-compose logs node Commented May 9, 2022 at 14:11
  • Updating the node configuration... May 9 16:10:33.192 - node.main: FULL access to RPC enabled; this is very risky. (addresses = :8732) May 9 16:10:33.331 - node.config.validation: the node configuration has been successfully validated. May 9 16:10:34.058 - node.config.validation: the node configuration has been successfully validated. May 9 16:10:34.059 - node.main: read identity file (peer_id = idtjmcuW3dbKbpBVSGEGdTiuR96HCi) May 9 16:10:34.060 - node.main: starting the Tezos node v13.0 (cb9f439e) May 9 16:10:34.060 - node.main: (chain = TEZOS_JAKARTANET_2022-04-27T15:00:00Z)
    – fr3ak
    Commented May 9, 2022 at 16:12
  • I can't paste here full output
    – fr3ak
    Commented May 9, 2022 at 16:12
  • Everything seems fine. The RPC call simply times out? Did your setup work fine with Ithacanet? Commented May 9, 2022 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.