0

I am just days into learning how to build a dapp on Tezos for my thesis. I tried replicating the steps from Claude's tutorial - https://hackernoon.com/build-your-first-dapp-on-tezos-rwgl3ymb

I ran into a problem (unknown subcommand compile-contract) when I was trying to compile the contracts via truffle in the terminal. Would be great if you can tell me what is causing the error or point me right direction :D Many thanks in advanceenter image description here

2 Answers 2

0

I'm not familiar with Truffle, but Ligo is in very active development, and I believe they recently changed the compile-contract subcommand to compile contract (note lack of dash.) If you do ligo man compile you can see all of the other sub-commands of compile. I prefer ligo man compile -v 0 to make it more readable.

0

I am pretty sure truffle doesn't support tezos updates anymore. I've switched months ago (after running constantly into issues like the one you're describing) to compiling directly with the ligo cli, and testing and deploying contracts with pytezos.
https://ligolang.org/docs/manpages/ligo
https://pytezos.org/contents.html

1
  • Hey thanks for your clarification! I will look into the links you provided! Dec 24, 2021 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.