0

I sent the transaction report after upgrading from 10.0~ RC3 to V11.0.0,Now I can't send a transaction,what should i do

start node: ./tezos-docker-manager.sh start --rpc-port 8732

ubuntu@VM-0-13-ubuntu:/home$ /data/xtz/tezos-docker-manager.sh client transfer 0.623456 from yhb_test_1111 to ******************* --burn-cap 0.257 Disclaimer: The Tezos network is a new blockchain technology. Users are solely responsible for any risks associated with usage of the Tezos network. Users should do their own research to determine if Tezos is the appropriate platform for their needs and should apply judgement and care in their network interactions.

Node is bootstrapped. Rpc request failed:

  • meth: POST
  • uri: http://node:8732/chains/main/blocks/head/helpers/scripts/simulate_operation
  • error: The server doesn't authorize this endpoint (ACL filtering). Fatal error: transfer simulation failed ubuntu@VM-0-13-ubuntu:/home$

2 Answers 2

2

For me it works with the following parameters:

--rpc-addr 0.0.0.0:8732 --allow-all-rpc 0.0.0.0:8732

First one makes RPC listen for connections on any interface, and the second fixes ACL.

0

You need to allow RPC functionality. Check also the documentation on the new ACLs.

See if this works for you:

./tezos-docker-manager.sh start --rpc-port 8732 --allow-all-rpc 0.0.0.0:8732

2
  • It still doesn't work,report the same error The startup parameters in the in docker-compose.yml : command: tezos-node --net-addr :9732 --allow-all-rpc 0.0.0.0:8732 --network mainnet
    – hb Y
    Dec 7, 2021 at 1:47
  • You're going to have to play around with those settings unfortunately as those ACL flags are the only way to get the RPC working correctly.
    – utdrmac
    Dec 8, 2021 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.