0

Sorry, i'm kind of a noob here. I managed to get my personnal rpc node running on local network and it was fine for few weeks. I always had low connections but it worked (only 5 connections but it seemed fine). But after few weeks running, i now have 0 connections and the node don't work anymore : i can't do any transactions on temple and it shows only my tez balance, not the tokens balances.

Node is up to date. I read some solutions but it seems old ones talking about adding peers in peers.json. Are those solutions are still the right ones ? If yes, how do i find those peers ? I tried to delete the peers.json. I also tried to generate a new identity but nothing worked yet.

Thank you.

0

In my experience, the most common reason for this are the following:

  • you are running (and build) binaries from the wrong branch, for example, master branch instead of latest-release
  • you are somehow running on private mode (private mode requires you to connect to outside peers and is undiscoverable in the network)

In your case, you are connected to no peers which is unlikely due to what I will also mention. But if you have low number of peer connection, it's usually related to opening up the right ports (9732) to allow peers to connect to you.

0

When people say "add peers", they are referring to this script. Download this script to your computer, change the TZPATH (line 30) to match your environment then run the script.

Then use this tool to check if your inbound P2P port (9732) is open to the outside world. If not, then you need to use your router to forward incoming connections on this port to the computer running your node.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.