0

I have downloaded Tezos binaries from here:

https://github.com/serokell/tezos-packaging/releases

Took binaries-11.0-1.tar.gz, extracted, assigned permissions 755, but when I run any binary, like:

./tezos-node --version

I get:

Illegal instruction (core dumped)

All previous releases I have tried (latest production release was 10.3-1) worked just fine using this method of downloading.

3

This means your CPU does not have the required instruction set to run Tezos. There is an ongoing debate around this issue:

https://gitlab.com/tezos/tezos/-/issues/1788

The linked issue is about docker, but the overall issue is the same. The dev teams use the latest CPUs available to compile Tezos binaries. Which means, if you have an old CPU (even 2-3 years can be "old") then you might not have certain instruction sets.

Please comment on the issue so we can get the devs to stop doing this.

1
  • Thank you! Commented on that issue and built Tezos 11 from sources so it would work on my machine. For that, first we had to build OCaml because it also is not compatible :)
    – DimaA6_ABC
    Nov 16 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.