0

I've tried installing cargo on $HOME and /tmp to no avail. Can anyone help out?enter image description here

1
0

Installation of cargo and rust dependencies is covered in the following section of the documentation: https://tezos.gitlab.io/introduction/howtoget.html#install-rust.

1
  • thanks. I retried all steps on a new Digital Ocean droplet but I still get the same error <><> Error report <><><><><><><><><><><><><><><><><><><><><><><><><><><><><><><> ┌─ The following actions failed │ λ build conf-rust 0.1 └─ ╶─ No changes have been performed The packages you requested declare the following system dependencies. Please make sure they are installed before retrying: cargo I also followed the steps here to no avail: tezos.gitlab.io/introduction/howtoget.html#install-rust
    – silly_one
    Sep 13 at 4:44
0

I believe this is some issue related to the opam sandbox.

From root:

/root/.opam/opam-init/hooks/sandbox.sh build ls -a ..

drwxr-xr-x root .
drwxr-xr-x root ..
drwxr-xr-x root tezos

From a regular user:

/home/user/.opam/opam-init/hooks/sandbox.sh build ls -a ..

drwxr-xr-x user .
drwxr-xr-x user ..
drwxr-xr-x user .cargo
drwxr-xr-x user .opam
drwxr-xr-x user .rustup
drwxr-xr-x user .zcash-params
drwxr-xr-x user tezos
....

The above shows that the sandbox now handles the root directory differently and, because of that, it cannot find the cargo binaries located at ~/.cargo/bin/*.

You are probably using root.

My suggestion is that you create a new user and try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.