0

I'm debugging for a long time the tezo-nodes. Tried several ways to bake the binaries. But I still facing the same issues:

After some time syncing from scratch the node stop syncing and get stuck. The only way that I found to solve this is restarting the process running. I could add some automation to check if the node stop syncing and restart.But before execute this measure I prefer to investigate the root causes.

Right now we tried to: Deploy in docker, change disk type, deploy in Kubernetes,deploy on VM instances. Change the parameter --connections to 20

But the issue is always the same after some days of syncing it gets stuck.

The command that we are running is basically this one:
tezos-node run   --connections 20  --history-mode archive --rpc-addr :8732  --log-output /var/log/tezos.log

Can you please help with some ideas?

1

Have you tried raising the tezos-node log level to INFO or DEBUG?

By increasing log level, your node logs become more and more verbose allowing you to follow step by step what happens under the hood when the node gets stuck.

You can find more information on logs configuration on the Octex documentation https://tezos.gitlab.io/user/node-configuration.html#logging

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.