0

I tried to install tezos-client by using M1 version of homebrew (brew install tezos-client). and I received this error.

/opt/homebrew/Library/Homebrew/utils/github/api.rb:304:in `raise_error': Validation Failed: [{"message"=>"The listed users and repositories cannot be searched either because the resources do not exist or you do not have permission to view them.", "resource"=>"Search", "field"=>"q", "code"=>"invalid"}] (GitHub::API::ValidationFailedError)

I tried installing with x86-64 architecture with Rosetta homebrew but I received this error instead:

/usr/local/homebrew/Library/Homebrew/utils/github.rb:60:in `issues_for_formula': undefined method `full_name' for nil:NilClass (NoMethodError)

Is it possible to install tezos on Mac OS X?

0

It seems that this Tezos MR will allow Tezos to be built on MacOS arm64.

However, while it has been merged, its changes are not yet included in the current latest release (v10.0.0) AFAICT.

A tezos-packaging user was reportedly able to use this workaround using rosetta, it might help you as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.