Trying to build 9.6. Running this command -

rm -rf _opam _build  
make build-deps
eval $(opam env)

I have set every version of rustc from 1.44.0, 1.52, 1.53... nothing works. I have set an override to then later unset it, but nothing.

I've also clean installed rust/rustup.

Any help would greatly appreciated!

<><> Processing actions <><><><><><><><><><><><><><><><><><><><><><><><><><>  🐫 
∗ installed base-bigarray.base
∗ installed base-threads.base
∗ installed base-unix.base
∗ installed ocaml-base-compiler.4.10.2
∗ installed ocaml-config.1
∗ installed ocaml.4.10.2
/Users/XXX/tezos/scripts//install_build_deps.rust.sh: line 39: override: command not found
Wrong Rust version. This is probably because you have used rustup 1.24.3 (ce5817a94 2021-05-31)
The Rust toolchain installer

    rustup [FLAGS] [+toolchain] <SUBCOMMAND>

    -v, --verbose    Enable verbose output
    -q, --quiet      Disable progress output
    -h, --help       Prints help information
    -V, --version    Prints version information

    <+toolchain>    release channel (e.g. +stable) or custom toolchain to set override

    show           Show the active and installed toolchains or profiles
    update         Update Rust toolchains and rustup
    check          Check for updates to Rust toolchains and rustup
    default        Set the default toolchain
    toolchain      Modify or query the installed toolchains
    target         Modify a toolchain's supported targets
    component      Modify a toolchain's installed components
    override       Modify directory toolchain overrides
    run            Run a command with an environment configured for a given toolchain
    which          Display which binary will be run for a given command
    doc            Open the documentation for the current toolchain
    man            View the man page for a given command
    self           Modify the rustup installation
    set            Alter rustup settings
    completions    Generate tab-completion scripts for your shell
    help           Prints this message or the help of the given subcommand(s)

    Rustup installs The Rust Programming Language from the official
    release channels, enabling you to easily switch between stable,
    beta, and nightly compilers and keep them updated. It makes
    cross-compiling simpler with binary builds of the standard library
    for common platforms.

    If you are new to Rust consider running `rustup doc --book` to
    learn Rust. in the past. Run the following command from your
favorite shell, and retry to install the dependencies:
$ rustup override unset
make: *** [build-deps] Error 1
make: dune: No such file or directory
make: *** [all] Error 1

3 Answers 3


The official guide for v9 release says you need Rust v1.44.0, but the latest guide says v1.52.0.

wget https://sh.rustup.rs/rustup-init.sh
chmod +x rustup-init.sh
./rustup-init.sh --profile minimal --default-toolchain 1.52.0 -y

source $HOME/.cargo/env

Then, download and run:

  • I've done all of this and followed the official guide, but it's still giving me the same error on 9.6, 10, and 10 RC2.
    – Kevyn
    Aug 7, 2021 at 19:01

Ok, I found out the source of my issue is Opam installs a second version of Rust via Homebrew, which is (1.53). When you run make build-deps, it'll use that version and not the version you've set via rustup, so during the setup of Opam, run seperately brew uninstall rust, and that'll remove the 1.53 version.

Next, install Rust from using the command on Rust's website.

Then when prompted choose 2) Custom installation, and skip the first question, set toolchain to 1.44.0, and the skipped the remaining questions.

Then source $HOME/.cargo/env

That correctly setup Rust and Rustup, and I no longer get that error.


You should not use 9.6 It's highly recommended to transition to the 9.7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.