I'm following the official docs in the Tezos repo about how to generate a new wallet via a connected ledger device.

I have the ledger open to the correct screen and unlocked. However when I run tezos-client list connected ledgers I see nothing.

I have also tried running this command as root, and I still see nothing.

I am using the public mainnet node provided by smartpy, and I'm on the latest MacOS version (11.2.3 (20D91)). My ledger firmware is also up to date.

Ledger Live also works.

Is using a ledger with a public node possible?

2 Answers 2


Is using a ledger with a public node possible?

Yes, I do it all the time.

this command as root, and I still see nothing

Then you have a USB and/or permissions issue. Not sure on Mac, but on linux you would check dmesg and see if the USB drivers are having an issue with the device.

Check the official support on this.

Since you are on Mac, does Ledger Live work? If not, then you have a USB issue. Try a different cable.

  • Can I ask what public node are you using
    – Whirlybird
    Commented Aug 1, 2021 at 23:26
  • and also do you have to run as root in order to find your ledger? I'm asking in your specific case, not in general.
    – Whirlybird
    Commented Aug 1, 2021 at 23:57
  • I appreciate you confirming that it's possible to use ledger with a public node. That was helpful and reassured me, thank you.
    – Whirlybird
    Commented Aug 2, 2021 at 0:35

This ended up being a combination of issues and I want to leave some good help/debugging steps here for future Mac users with this issue.

First, make sure you have the latest Ledger Live version, and the latest firmware on your ledger. You can open Ledger Live and click the "manager" link in the left hand navigation menu of the ledger live app. If your device firmware is not up to date, you will see a blue banner telling you that there is a new firmware version and asking you to install.

Ledger has a good step by step guide on how to debug most of this issue. These steps are an excerpt from the link above:

Most connection issues occur because Ledger Live doesn’t have the required rights on the computer. Please enable full disk access by following the instructions below:

  1. Open System Preferences.
  2. Go to Security & Privacy.
  3. In the Privacy tab, add Ledger Live to the Full Disk Access list.
  4. Try again to connect your Ledger device to Ledger Live.

The above steps did not immediately work, and only worked once I restarted my computer.

There is another step suggested by ledger if the above steps and a restart don't work, and this is:

Another solution is to reset the PRAM or NVRAM on your Mac. Follow Apple's official instructions to do so before you retry in Ledger Live.

*When running tezos-client list connected ledgers you will need to have the Tezos wallet open on the Ledger device itself, you can know that's open because you will see the "Application is ready" message on the Ledger device screen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.