0

I have two different Tezos 'accounts' (each with its own tz1 address) on my Ledger Nano X, which I interface with using the default Tezos Wallet app provided in Ledger Live. One of them was created first, has more XTZ, and seems to be the 'main' one. Let's call the other account 'secondary'. I would like to bid on a Tezos domain using my 'secondary' account. However, when I go to app.tezos.domains, click 'connect wallet' in the top-right, and connect with Ledger, I get a prompt to share my 'main' tz1 address, rather than the 'secondary' address*. Is there some way of controlling which public key gets shared?

[*] Also there's a typo: the address is displayed under the title "Publick Key Hash"

0

This is an issue with the Tezos Domain website and not anything to do with your ledger. Whenever any application or wallet interfaces with the Ledger, it can set the BIP path for the key to use. Your "secondary" key is exactly that. Ledger Live just manages this aspect behind the scenes. You need to ask the TezosDomain people to give you the option of using a different address.

1
  • Gotcha. Looks like in my case the solution was to use the Temple web wallet as an intermediary. Apr 22 at 0:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.