1

I have a problem with Edo protocol version.

On my computer, I tried to install tezos-node and tezos-client from PPA, with OPAM and from gitlab sources. With these 3 ways, I always have the same problem: tezos-client doesn't use same protocol as tezos-node.

On startup, node shows PtEdoTez:

~/.opam/for_tezos/bin/tezos-node run --rpc-addr 127.0.0.1:8732
Feb 16 15:43:33.494 - node.main: read identity file (peer_id = idtYAvzx1CZpDZGzWfGsZv6u5mkCzr)
Feb 16 15:43:33.494 - node.main: starting the Tezos node (chain = TEZOS_EDONET_2020-11-30T12:00:00Z)
Feb 16 15:43:33.494 - node.main: disabled local peer discovery
Feb 16 15:43:33.581 - node: shell-node initialization: bootstrapping
Feb 16 15:43:33.687 - node: shell-node initialization: p2p_maintain_started
Feb 16 15:43:33.687 - external_block_validator: initialized
Feb 16 15:43:33.861 - external_block_validator: block validator process started with pid 1170415
Feb 16 15:43:36.054 - node.validator: activate chain NetXSp4gfdanies
Feb 16 15:43:36.055 - p2p.maintenance: too few connections (0)
Feb 16 15:43:36.060 - node.chain_validator: no prevalidator filter found for protocol
Feb 16 15:43:36.060 - node.chain_validator:   PtEdoTezd3RHSC31mpxxo1npxFjoWWcFgQtxapi51Z8TLu6v6Uq
Feb 16 15:43:36.072 - node.main: starting RPC server on ::ffff:127.0.0.1:8732 (tls = false)
Feb 16 15:43:36.072 - node.main: the Tezos node is now running
Feb 16 15:43:36.764 - validator.chain: Sync_status: unsync
Feb 16 15:43:38.163 - validator.chain: Chain is bootstrapped
Feb 16 15:43:38.165 - validator.chain: Sync_status: sync

But node is v8.2:

 ~/.opam/for_tezos/bin/tezos-node --version
6102c808 (2021-02-10 22:57:06 +0100) (8.2)

Tezos-client using PtEdo2Zk:

~/.opam/for_tezos/bin/tezos-client --protocol PtEdo2ZkT9oKpimTah6x2embF25oss54njMuPzkJTEi5RqfdZFA
Warning:
  
                 This is NOT the Tezos Mainnet.
  
           Do NOT use your fundraiser keys on this network.

Warning:
  The protocol provided via `--protocol` (PtEdo2ZkT9oK)
  is not the one retrieved from the node (PtEdoTezd3RH).

Tezos-client using PtEdoTez:

~/.opam/for_tezos/bin/tezos-client --protocol PtEdoTezd3RHSC31mpxxo1npxFjoWWcFgQtxapi51Z8TLu6v6Uq
Error:
  Wrong value for command line option --protocol.
  Value PtEdoTezd3RHSC31mpxxo1npxFjoWWcFgQtxapi51Z8TLu6v6Uq does not correspond to any known protocol.

During building, I had messages saying that it was building PtEdo2Zk for all components. I didn't get any PtEdoTez in logs. My node and my client have been built at the same time. I don't understand why they don't have the same protocol.

Am I missing something ?

thanks

4
  • did you try running make clean before make build-deps and then make? it feels like you have some legacy files. Everything that is PtEdoTez should not be used, PtEdo2Zk is the real protocol.
    – Frank
    Feb 16 at 15:20
  • I've just tried to build it again, with the make clean, but the result is still the same. Is there any directory I can delete to remove some cache or other ... ?
    – Alex
    Feb 16 at 16:22
  • Your node is connecting to the wrong Edonet. You need to update your list of peers (the file peers.json in the data-dir of your node) and re-bootstrap your node on the new Edonet that was launched last week. Feb 16 at 16:48
  • I starded from scratch again. I removed binaries and directories, then I installed node and client from PPA, and started the node. I get this log: node.validator: fetching protocol PtEdoTezd3RHSC31mpxxo1npxFjoWWcFgQtxapi51Z8TLu6v6Uq Does it mean that I run the wrong binary or it's just a bootstrapping issue ? And what can I do to bootstrap with right peers or right protocl ?
    – Alex
    Feb 17 at 9:39
1

If you use v8.2 or master branch from the https://gitlab.com/tezos/tezos/ you need to put in your tezos-node(~/.tezos-node) DATA_DIR/config.json the section in order to use edo2net (PtEdo2Zk) network:

"network":
    { "genesis":
        { "timestamp": "2021-02-11T14:00:00Z",
          "block": "BLockGenesisGenesisGenesisGenesisGenesisdae8bZxCCxh",
          "protocol": "PtYuensgYBb3G3x1hLLbCmcav8ue8Kyd2khADcL5LsT5R1hcXex" },
      "genesis_parameters":
        { "values":
            { "genesis_pubkey":
                "edpkugeDwmwuwyyD3Q5enapgEYDxZLtEUFFSrvVwXASQMVEqsvTqWu" } },
      "chain_name": "TEZOS_EDO2NET_2021-02-11T14:00:00Z",
      "sandboxed_chain_name": "SANDBOXED_TEZOS",
      "default_bootstrap_peers":
        [ "edonet.tezos.co.il", "188.40.128.216:29732", "edo2net.kaml.fr",
          "edonet2.smartpy.io", "51.79.165.131", "edonetb.boot.tezostaquito.io" ] }
2
  • It works ! Thanks a lot. But does it mean that tezos-node config init --network edonet does not set the right network configuration ?
    – Alex
    Feb 19 at 13:21
  • Yes, it is, because the PtEdo2Zk test network is called edo2net.
    – dmirg
    Feb 23 at 21:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.