0

I am receiving below error when starting the Tezos service. I have installed on the laptop with success so it must be something with the environment but I cannot wrap my head around it...

Feb 12 00:32:13 boomStaker tezos-node-start[54569]: Feb 12 00:32:13.992 - node.main: starting the Tezos node (chain = TEZOS_MAINNET)
Feb 12 00:32:13 boomStaker tezos-node-start[54569]: Feb 12 00:32:13.992 - node.main: disabled local peer discovery
Feb 12 00:32:13 boomStaker tezos-node-start[54569]: Feb 12 00:32:13.996 - node: shell-node initialization: bootstrapping
Feb 12 00:32:13 boomStaker tezos-node-start[54569]: Feb 12 00:32:13.998 - p2p.welcome: cannot accept incoming connections
Feb 12 00:32:13 boomStaker tezos-node-start[54569]: tezos-node: Error:
Feb 12 00:32:13 boomStaker tezos-node-start[54569]:               Unix error in socket: Address family not supported by protocol
Feb 12 00:32:13 boomStaker tezos-node-start[54569]:             
Feb 12 00:32:14 boomStaker systemd[1]: tezos.service: Main process exited, code=exited, status=1/FAILURE
Feb 12 00:32:14 boomStaker systemd[1]: tezos.service: Failed with result 'exit-code'.
Feb 12 00:32:19 boomStaker systemd[1]: tezos.service: Scheduled restart job, restart counter is at 32.

Here is the commands I run:

sudo tezos-node identity generate --data-dir /mnt/sda1/tezos/
- Stored the new identity (idtjwGHCJ8TnqkRn5kurdeAD7o2rJT) into '/mnt/sda1/tezos/identity.json'.

sudo tezos-node config init --data-dir /mnt/sda1/tezos/
Created /mnt/sda1/tezos/config.json for default network: mainnet.

sudo tezos-node run --data-dir /mnt/sda1/tezos/
Feb 12 09:38:26.473 - node.main: read identity file (peer_id = idtjwGHCJ8TnqkRn5kurdeAD7o2rJT)
Feb 12 09:38:26.473 - node.main: starting the Tezos node.... tezos-node: Error: Unix error in socket: Address family not supported by protocol
5
  • Show the command you are using to start tezos-node
    – utdrmac
    Feb 12 at 3:19
  • For more logging information you can try running LWT_LOG="* -> debug" tezos-node ...
    – arvidj
    Feb 12 at 7:12
  • The command I am using is tezos-node run or systemctl start tezos.service (which is just a copy of the tezos-node-mainet.service with a customn --data-dir
    – boom123psy
    Feb 12 at 8:29
  • sudo tezos-node identity generate --data-dir /mnt/sda1/tezos/ - Stored the new identity (idtjwGHCJ8TnqkRn5kurdeAD7o2rJT) into '/mnt/sda1/tezos/identity.json'. sudo tezos-node config init --data-dir /mnt/sda1/tezos/ Created /mnt/sda1/tezos/config.json for default network: mainnet. sudo tezos-node run --data-dir /mnt/sda1/tezos/ Feb 12 09:38:26.473 - node.main: read identity file (peer_id = idtjwGHCJ8TnqkRn5kurdeAD7o2rJT) Feb 12 09:38:26.473 - node.main: starting the Tezos node.... tezos-node: Error: Unix error in socket: Address family not supported by protocol
    – boom123psy
    Feb 12 at 8:38
  • has this something to do that ipv6 is disabled?
    – boom123psy
    Feb 12 at 9:06
0

it looks like you are using the default identity, this identity should look like this :

    { "bootstrap-peers":
        [ "boot.tzbeta.net", "116.202.172.21", "95.216.45.62" ],
      "listen-addr": "[::]:9732" } }

the address "[::]:9732" is an ipv6 address, try replacing it with its ipv4 equivalent "0.0.0.0:9732"

1
  • yes you are right but I am still facing issues with the RPC addr. If IPv6 is disabled in OS and the config.json contains "rpc": { "listen-addr": "0.0.0.0:8733" } the tezos-node refuses to start. If I enable the IPV6, no changes in the config, I can still see in the logs:node.main: starting RPC server on ::ffff:0.0.0.0:8733, so its like it ignores the conf and wants to listen also on ipv6. i have changed the port to 8733, so i can verify its loading the correct config...
    – boom123psy
    Feb 26 at 8:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.