0

I've just install Tezos with:

sudo add-apt-repository ppa:serokell/tezos && sudo apt-get update
sudo apt-get install tezos-client
sudo apt-get install tezos-node

tezos-node --version: d74e7b6d (2021-01-08 16:06:59 +0100) (8.1)

tezos-node run --rpc-addr 127.0.0.1:8733 --data-dir ~/tezos-edonet:

Feb  1 11:32:43.097 - node.main: read identity file (peer_id = idqpmwJizogKdrjCdvim7UY29LuqYd)
Feb  1 11:32:43.097 - node.main: starting the Tezos node (chain = TEZOS_EDONET_2020-11-30T12:00:00Z)
Feb  1 11:32:43.097 - node.main: disabled local peer discovery
Feb  1 11:32:43.307 - node: shell-node initialization: bootstrapping
Feb  1 11:32:43.366 - node: shell-node initialization: p2p_maintain_started
Feb  1 11:32:43.366 - external_block_validator: initialized
Feb  1 11:32:43.490 - external_block_validator: block validator process started with pid 114138
Feb  1 11:32:44.986 - node.validator: activate chain NetXSp4gfdanies
Feb  1 11:32:44.986 - p2p.maintenance: too few connections (0)
Feb  1 11:32:44.995 - node.main: starting RPC server on ::ffff:127.0.0.1:8733 (tls = false)
Feb  1 11:32:44.995 - node.main: the Tezos node is now running
...

Then bootstrapping is ok until block BKyqtJzjrJcHn7pqZjHtDLu5VM2RYK1zcm8KHfxsH8XHvcGsYjP:

Feb  1 11:37:02.459 - validator.block: validation of block BKyqtJzjrJcHn7pqZjHtDLu5VM2RYK1zcm8KHfxsH8XHvcGsYjP failed
Feb  1 11:37:02.459 - validator.block: Request pushed on 2021-02-01T10:37:00.934-00:00, treated in 1.467s, completed in 57.142ms , 
Feb  1 11:37:02.459 - validator.block: Inconsistent hash:
Feb  1 11:37:02.459 - validator.block:   got: CoW6PkFHmFyrrYn5dY7Mw4WyAJ3fcyTys6tQQjfwBJm2uEPy2azf
Feb  1 11:37:02.459 - validator.block:   expected: CoUpwMzsjA2wFQNtx5Wtu9YnfJjGx4QCw59kQVfhbrAhtaHmEexa
Feb  1 11:37:02.459 - node.validator.bootstrap_pipeline: unexpected error while fetching headers:
Feb  1 11:37:02.459 - node.validator.bootstrap_pipeline:   Inconsistent hash:
Feb  1 11:37:02.459 - node.validator.bootstrap_pipeline:     got: CoW6PkFHmFyrrYn5dY7Mw4WyAJ3fcyTys6tQQjfwBJm2uEPy2azf
Feb  1 11:37:02.459 - node.validator.bootstrap_pipeline:     expected: CoUpwMzsjA2wFQNtx5Wtu9YnfJjGx4QCw59kQVfhbrAhtaHmEexa
Feb  1 11:37:02.459 - validator.peer: New branch BLtLVFfgnNFS7SQ3KjPqoqcjTGhD3CDPE5tqtop4V5A2MXRBj4b, locator length 188820
Feb  1 11:37:02.459 - validator.peer:  Request pushed on 2021-02-01T10:36:04.061-00:00, treated in 163us, completed in 58.397s , 
Feb  1 11:37:02.459 - validator.peer: Inconsistent hash:
Feb  1 11:37:02.459 - validator.peer:   got: CoW6PkFHmFyrrYn5dY7Mw4WyAJ3fcyTys6tQQjfwBJm2uEPy2azf
Feb  1 11:37:02.459 - validator.peer:   expected: CoUpwMzsjA2wFQNtx5Wtu9YnfJjGx4QCw59kQVfhbrAhtaHmEexa
Feb  1 11:37:02.460 - validator.peer: Worker crashed [node_peer_validator]:
Feb  1 11:37:02.460 - validator.peer: Inconsistent hash:
Feb  1 11:37:02.460 - validator.peer:   got: CoW6PkFHmFyrrYn5dY7Mw4WyAJ3fcyTys6tQQjfwBJm2uEPy2azf
Feb  1 11:37:02.460 - validator.peer:   expected: CoUpwMzsjA2wFQNtx5Wtu9YnfJjGx4QCw59kQVfhbrAhtaHmEexa
Feb  1 11:37:24.705 - node.validator.bootstrap_pipeline: still fetching headers from peer idrV42LAuqTKtR86s84ovNmp9qZ1J5: 1000/11990
Feb  1 11:37:30.809 - node.validator.bootstrap_pipeline: still fetching headers from peer idtnrrvy9kcMiFttbwFbmCBKdHVGGP: 1000/12224

It's looping on that. I've tried to delete my datadir to restart from scratch. The same problem happens.

Is there something to do to be able to complete bootstrapping ?

Thanks

5
  • I tried to reproduce your error with the v8.1 Tezos node (under Ubuntu x86_64), compiling from sources, but I didn't encounter this problem. Try to build from sources : tezos.gitlab.io/introduction/… And update your node to v8.1 using : git fetch git checkout v8.1 make build-deps eval $(opam env) make Feb 2 at 8:34
  • I tried to build from sources via Opam and run this new "tezos-node" binary, the problem is still there. So I've clear my data-dir to start from scratch with the new binary. Bootstrap is running, let's wait ... By th way, I should precise that, on the same computer, I have another tezos-node running on Delphinet. Different data-dir, different RPC ports ... My Delphinet is running well. But I hope it's not a problem to run two "tezos-node" instance at the same time ?
    – Alex
    Feb 2 at 10:52
  • It's not a problem if they are running on different ports. Please feel free to show the logs if anything goes wrong Feb 2 at 12:18
  • The problem is still there. Here's the logs when it goes wrong (it's the same as above): Feb 2 14:02:46.834 - prevalidator.NetXSp4gfdani.PtEdoTezd3RH: Request pushed on 2021-02-02T13:02:46.809-00:00, treated in 44.972us, completed in 23.975ms Feb 2 14:02:46.837 - validator.chain: Update current head to BLa7uGDqijEzjfxGbHzuNLRapxnDC3E1BuCDZfQem8U4dFzYipn (level 42992, timestamp 2020-12-16T00:46:16-00:00, fitness 01::000000000000a7ef), same branch Feb 2 14:02:46.837 - validator.chain: Request pushed on 2021-02-02T13:02:46.793-00:00, treated in 1.176ms, completed in 38.742ms Feb 2 14:02:46.978 -
    – Alex
    Feb 2 at 13:27
  • Did you meet issues while building from sources ? if yes, please share the logs Feb 2 at 14:54

Browse other questions tagged or ask your own question.