0

I am running a multinetwork node, with a mainnet node (P2P port 9732, RPC port 8732) and a delphinet node (P2P port 9733, RPC port 8733, config.json and data is in folder ~/tezos-delphinet/). Nodes are syncing and everything is fine.

I wanted to test with some free tez, so I went to the Tezos Faucet, dowloaded the JSON file and like the guide said I tried to activate the account (the guide should include the base-dir, addr and port flags, I think!):

tezos-client --base-dir ~/tezos-delphinet/ --addr 127.0.0.1 --port 8733 activate account wallet1 with ~/tezos-delphinet/tz1YDX6MLpHwziXQfKBmAMDcU6reBEyrfiyn.json

The node is bootstrapped. The response is:

Waiting for the node to be bootstrapped before injection...
Current head: BLNMurhtj4c2 (timestamp: 2020-09-04T20:42:33-00:00, validation: 2020-09-04T20:42:34-00:00)
Current head: BLHvPjLmXPoa (timestamp: 2020-09-04T20:43:23-00:00, validation: 2020-09-04T20:43:24-00:00)
Current head: BLFL36V6rd19 (timestamp: 2020-09-04T20:44:21-00:00, validation: 2020-09-04T20:44:22-00:00)


^CSep  4 22:45:12 - client.main: Received the INT signal, triggering shutdown.
Fatal error:
  Lwt.Resolution_loop.Canceled

I terminated because it took too long.

tezos-client --base-dir ~/tezos-delphinet --addr 127.0.0.1 --port 8733 activate account wallet1 with ~/tezos-delphinet/tz1YDX6MLpHwziXQfKBmAMDcU6reBEyrfiyn.json
Error:
  The secret_key alias wallet1 already exists.
    The current value is unencrypted:edsk3CPr7____________.
    Use --force to update

But the balance is zero:

tezos-client --base-dir ~/tezos-delphinet --addr 127.0.0.1 --port 8733 get balance for wallet1
0 ꜩ
0

Your node is NOT bootstrapped. If it was, you would NOT see those timestamp messages.

| improve this answer | |
  • It is... that's one problem. In fact, when I tried again it said "The secret_key alias wallet1 already exists." so it injected the operation. – Babell Sep 4 at 21:40
  • Update current head to BKwrnZd1Dkh2wEt8wQLtFq4oT9rVRnBtScCfscTfJQRKUmicAtf (level 480, timestamp 2020-09-04T21:40:35-00:00, fitness 01::00000000000001df) – Babell Sep 4 at 21:42
  • tezos-client will not inject operations to a node that is not bootstrapped. If your node is indeed bootstrapped then tezos-client will NOT output the clear-as-day phrase "Waiting for the node to be bootstrapped". – utdrmac Sep 5 at 1:18
  • I agree with you and assume that what I described is a bug. – Babell Sep 5 at 7:44
  • The bug being that the account was created even though the operation was never injected? – arvidj Sep 7 at 5:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.