1

I have successfully set up Kiln for baking but recently missed my first baking slot, after waiting for several weeks for my first slot :(

Endorsing works fine

New baking slot found (...) at (...)for ledger_kiln after BLNMsdJiyXjR.
Error while injecting block
Found no ledger corresponding to ledger://.../ed25519/0h/0h/0h.

Endorsing works fine though and tezos-client seems to recognize the ledger

ronny@tezos-node:~$ tezos-client -P 8733 show ledger ledger://.../ed25519/0h/0h/0h

Found ledger corresponding to ledger://.../ed25519/0h/0h/0h:
* Manufacturer: Ledger
* Product: Nano S
* Application: Tezos Baking 2.2.5 (git-description: "")
* Curve: `ed25519`
* Path: `44h/1729h/0h/0h/0h` [0x8000002C; 0x800006C1; 0x80000000; 0x80000000; 0x80000000]
* Public Key: ...
* Public Key Hash: ...

Any ideas on what might be wrong? Thank you!

1
1

Sorry to hear that!

There are many different reasons why block or endorsement could be missed, such as internet connectivity etc - however we can rule out many of those in this case because we see your baker identified the baking opportunity, attempted to bake, but it seems it wasn't not able to find your Ledger device. This may be of no fault of your own, but instead perhaps an intermittent connectivity issue. The most comprehensive summary on Ledger connectivity I've written can be found here - Debug of missed an endorsement.

If you'd like to mail your node and baker logs to tezos[at]obsidian.systems we can take a look - this may help diagnose the issue more broadly for the community as a whole.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.