4

I'm currently trying to set up a zeronet node on my server. I followed the "build from sources" instructions provided in the developer resources (https://tezos.gitlab.io/introduction/howtoget.html) - I checked out the zeronet branch before building anything.
I started the node with these commands (there is also a Carthagenet node running on the same server, hence the explicit port numbers):

tezos-node identity generate --data-dir ~/tezos-zeronet/ 26
tezos-node run --rpc-addr=127.0.0.1:9733 --net-addr=127.0.0.1:8733 --data-dir ~/tezos-zeronet/

Once started, the node warns about not having any connections (p2p.maintenance: Too few connections (0)). Starting it with -vvv gets us a little more info:

p2p.connect_handler: authenticate: [2600:1f11:342:de00::1:9732]:19732 -> failed
p2p.connect_handler: Error:
p2p.connect_handler:   IO error: connection with a peer is closed.

tezos-client -P 9733 bootstrapped seems to be stuck forever after outputting
Current head: BLockGenesis (timestamp: 2019-08-06T15:18:56-00:00, validation: 2020-06-02T11:39:48-00:00)

I don't use a config file and peers.json doesn't list any nodes. I've read posts from others having a similar problem on Carthage or Mainnet, and people proposed to add peer addresses to the config file (e.g. here https://gitlab.com/tezos/tezos/-/issues/265), however I couldn't find any good sources to obtain a list of nodes for zeronet.

I understand that zeronet has only few nodes and the bootstrapping might take a while, but it's been running for almost 24 hrs with no progress. I can imagine my node being grey or blacklisted, because I accidentally started it with an identity of lower level (24) the first time. But this was almost 2 weeks ago, so I'm guessing my node should have been greenlighted again by now.

Any suggestions as to what I'm doing wrong or what the problem might be are highly appreciated!

3

You may need to input a public node to bootstrap in your peer list; https://zeronet.smartpy.io is available.

| improve this answer | |
  • That did the trick, thanks! Although I'm wondering why the hardcoded bootstrap peers didn't work... – temrawr Jun 9 at 14:55
  • There are not that many nodes on zeronet and some have maxed out their number of connections. That happened to us as well recently. – FFF Jun 10 at 1:07
0

You need to specify the network when running the node by adding --network zeronet. It is automatically done in the Carthagenet script. Without this option, mainnet is the "default network".

| improve this answer | |
  • The --network option is only available on the latest-release branch and only provides the built-in networks mainnet, carthagenet & sandbox. As I built from the zeronet branch, I'm assuming the binaries only know zeronet. tezos-client bootstrapped explicitly warns me that the nodes runs on zeronet. – temrawr Jun 3 at 13:04
  • 1
    Oh, right. Maybe there is not enough zeronet users anymore. Indeed, the network is using a development version of the previous protocol. It is thus completely outdated. I recommand using Carthagenet instead. – vect0r Jun 8 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.