1

I looked at questions like Signed bytes and encodedSignature explanation? and Ledger with remote signer - health check but I couldn't find a way to check that my remote signer was working properly.

So, after having successfully imported the secret key from the remote signer, I executed this command:

./tezos-client --addr localhost -R http://<my-remote-signer-url>:<my-remote-signer-port>/<tz1-address> sign bytes 0x03 for my-remote-account

My Ledger Nano S, which was running the Baking app and working as normal showing the "chain", "last block", "baking key" messages, suddenly stopped and it froze. The response from the tezos-client command was:

Error:
  Unregistred error:
    { "kind": "permanent", "id": "signer.ledger",
      "ledger-error": "Application level error (sign-with-hash): Parse error" }

Note: I tried sending a transaction (using --dry-run) and the Wallet app correctly prompted the confirmation request.

2

0x03 is for generic operations, like transfers. The ledger baking app cannot sign 0x03; it will only sign bytes beginning with 0x01, and 0x02 (blocks, endorsements). You need to exit the baking app and load the wallet app on your ledger in order to execute transfers.

| improve this answer | |
  • Yes, for the transfers I did use the wallet app and as said it worked fine. – Babell May 5 at 6:57
  • Anyways, I think it should not crash like that without any error. – Babell May 5 at 7:14
  • For transfers, 0x03, you cannot use the baking app on your Ledger. That's why it is crashing. Yes, it should behave better. Open a support ticket with Ledger since they make the Tezos ledger apps. – utdrmac May 5 at 18:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.