1

https://github.com/stove-labs/workshop-notarization/tree/dev/ui

I'm trying to set the repo up and make it run, but I would come across the error mentioned on title when I execute yarn test.

Things I tried:

  1. Make sure both taquito and tezbridge installed.
  2. I inserted the script of ·< src="https://www.tezbridge.com/plugin.js">· to the head of the ./public/index.html
  3. I configured the signer (currently I select alice as the signer) on https://www.tezbridge.com/index.html?signer.
  4. As the sandbox is running on localhost:8732, I reset the network to "http://localhost:8732" on the webpage too.

It seems my guesses are all wrong. The error persists. Would anyone lend a hand? Many thanks.

0

Thanks for checking out the notarization workshop! Try running the UI directly by ‘npm run start’ instead. I suspect the ‘public/index.html’ may not be used in the test suite for the UI - which we haven’t touched for the workshop itself

| improve this answer | |
  • Thank you Matej. I tried 'npm run start' and encountered another error. It seems something wrong with the ts-loader according to the error msg. "../sdk/src/tezos-notary-sdk.ts 10:14 Module parse failed: The keyword 'public' is reserved (10:14) You may need an appropriate loader to handle this file type, currently no loaders are configured to process this file.". Does it mean I need to edit the webpack.config.js under config folder? I'm not very familar with js or react or anything, so spare me if this question is dumb. :) – Michelle Song May 2 at 12:34
  • problem fixed by replace with a newly downloaded ui folder and compile everything from the start. – Michelle Song May 4 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.