1

I'm using babylonnet.sh script to run docker.

My contract compiles. I output to a 'contract.txt' file.

Command is:

./babylonnet.sh client originate contract tezart transferring 0 from tz1ipQzB7tXwafCZn9hJBsJLqrAHWKjK6FNd running "container:contract.txt" --burn-cap 872 --fee 1000 --dry-run

Then it just hangs on 'Waiting for the node to be bootstrapped before injection...'. However, I upgraded and still get this error.

I upgraded to carthagenet, which I did using curl to download the carthagenet.sh. I deleted my older docker cache too. I ran and left it, but then I noticed this:

Apr 13 08:51:01 - node.validator.bootstrap_pipeline: 
Apr 13 08:51:01 - validator.peer: Worker crashed [validator-peer_91]:
Apr 13 08:51:01 - validator.peer: Failed to checkout the context with hash CoUfZgdpUBkt

Running this command ./carthagenet.sh client get timestamp I get:

Warning:

                 This is NOT the Tezos Mainnet.

     The node you are connecting to claims to be running on the
               Tezos Carthagenet DEVELOPMENT NETWORK.
          Do NOT use your fundraiser keys on this network.
          Carthagenet is a testing network, with free tokens.

2020-01-07T17:17:15Z
  • 1
    Failed to checkout the context typically means the database is corrupted. You should completely trash all your docker containers, and any volumes, and start over from scratch, beginning with carthagenet. As a side comment, I hope you're beginning to see why most people don't use docker ;-) It's far easier to just compile and run yourself than mess with docker. – utdrmac Apr 13 at 14:13
2

The babylonnet was terminated about 2 weeks ago. It is no longer supported. You should be on carthagenet now.

"Waiting for the node to be bootstrapped" means your node is not yet synchronized with the rest of the network. You cannot submit operations until you are in sync. On carthagenet, this might take about 24 hrs to sync.

| improve this answer | |
  • Oh, ok. I'll check it out thanks. This is kind of painful for a noob haha – Mark Robson Apr 11 at 13:54
  • @MarkRobson Please mark as answered if that's good for you. Thanks. – utdrmac Apr 11 at 17:14
  • I will when/if it works. Just tried again and it is still hanging. I activated one account successfully, so something is working – Mark Robson Apr 12 at 12:22
  • I still have the same issue with carthagenet. This is draining – Mark Robson Apr 12 at 16:57
  • sorry @utdrmac, this is not the correct answer. If you curl the cathargenet.sh, and get it working then I will believe you :-) – Mark Robson Apr 13 at 10:44
0

Having ran into lots of issues (timestampts etc, flags such as main branch etc etc) I resorted to using Teztool. I got the network up and running in a couple of minutes and can originate a contract. I'm dumping the .sh script.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.