0

I generated a new address on a node and then overwrote it. I have the public key hash (starts with 'edpk') and the password. I also have the private key hash (starts with 'encrypted:edesk1') I imported the public key:

$tezos-client show address <name> -S

Hash: tz1...
Public Key: edpk...

When I run:

$tezos-client import secret key <name> encrypted:edesk1...

the response is :

Enter password for encrypted key: 
Error:
  public and secret keys '<name>' don't correspond, please don't use --force

In the above examples. I replaced the actual name I gave the wallet with '< name>', however when I run the command I am replacing < name> with the actual alias.

Can anyone help me?

0

Reset everything. Run tezos-client forget address <alias> --force I hope you understand that <name> is not a literal string and that you should be replacing that with real values: Example: tezos-client forget address mykey1 --force

Then, ONLY import the encrypted secret key as you did above. The client will automatically extract the public key hash, and the public key for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.