2

I am using tezos-node to synchronize carthagenet chain. My config file is

{ "data-dir": "/data/install/tezos/node-data",
  "rpc": { "listen-addrs": [ "0.0.0.0:20340" ] },
  "p2p":
    { "bootstrap-peers": [ "boot.tzbeta.net" ], "listen-addr": "[::]:20339",
      "limits":
        { "connection-timeout": 10, "max-download-speed": 102400,
          "max-upload-speed": 102400, "max_known_points": [ 400, 300 ],
          "max_known_peer_ids": [ 400, 300 ] } },
  "log": { "output": "/data/install/tezos/Log/tezos-node.log" },
  "network":
    { "genesis":
        { "timestamp": "2019-11-28T13:02:13Z",
          "block": "BLockGenesisGenesisGenesisGenesisGenesisd6f5afWyME7",
          "protocol": "PtYuensgYBb3G3x1hLLbCmcav8ue8Kyd2khADcL5LsT5R1hcXex" },
      "chain_name": "TEZOS_ALPHANET_CARTHAGE_2019-11-28T13:02:13Z",
      "sandboxed_chain_name": "SANDBOXED_TEZOS",
      "default_bootstrap_peers":
        [ "tezaria.com", "34.76.169.218", "34.90.24.160",
          "carthagenet.kaml.fr", "104.248.136.94" ] } }

the latest log is

Apr  2 14:14:06 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:11 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:16 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:22 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:27 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:32 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:37 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:42 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:47 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:52 - p2p.maintenance: Too few connections (0)
Apr  2 14:14:57 - p2p.maintenance: Too few connections (0)

It seems to be disable connect to p2p network.

And, where is carthagenet snpshot, like https://github.com/Phlogi/tezos-snapshots?

1
  • Make sure you understand the difference between "mainnet" and "carthagenet". The former, "mainnet", is currently what is running across the entire Tezos network. "carthagenet" is a TESTING/DEVELOPMENT network which is completely isolated from mainnet. Are you running the correct software and connecting to the correct network? – utdrmac Apr 2 '20 at 14:40
1

Carthagenet uses different bootstrap peers ( source: https://gitlab.com/tezos/tezos/-/blob/master/src/bin_node/node_config_file.ml#L121 )

you can also just omit the bootstrap peers from the config file and it will use the hardcoded default ones.

Snapshots are available here:

https://snapshots.tulip.tools/#/

7
  • I am sure that my config is correct. After imported snapshot, I restart my node, and I still cannot connect to other peers. And then I clear bootstrap node config, it doesn't solve this problem. – saiwaixiaowangzi Apr 2 '20 at 9:18
  • does it start syncing if you start it without any config file at all? because if not that is most likely a networking issue – tuliptrader Apr 2 '20 at 9:40
  • yes, I think the node synchronize mainnet block – saiwaixiaowangzi Apr 2 '20 at 10:00
  • ah! I think i understand your problem...If you are on master branch, try running the node with --network carthagenet, we used to have multiple branches for each network, now everything is in one branch/node and users not running on mainnet should specify the network with this flag. hope it works with that – tuliptrader Apr 2 '20 at 10:09
  • 1
    yes, you can compile it from source but thats beyond the cope of this question. – tuliptrader Apr 2 '20 at 10:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.