2
    ./tezos/tezos-client -l --base-dir ./tmp --addr localhost --port 18731  --block genesis activate protocol PsCARTHAGazKbHtnKfLzQg3kms52kSRpgnDY982a9oYsSXRLQEb with fitness 1 and key activator and parameters ./tezos/sandbox-parameters.json --timestamp $(TZ='AAA+1' date +%FT%TZ)

I want to start nodes with carthage update

but the protocol isn't showing up !

Warning:
Failed to acquire the protocol version from the node
Rpc request failed:
 - meth: GET
 - uri: http://localhost:8732/chains/main/blocks/head/protocols
 - error: Unable to connect to the node: 
"Unix.Unix_error(Unix.ECONNREFUSED, "connect", "")"

Please check the hash too to confirm PsCARTHAGazKbHtnKfLzQg3kms52kSRpgnDY982a9oYsSXRLQEb

2
  • The ports (in the command and in the error message) do no seem to match. Anyway, the problem is that the client cannot connect to the node, not that the protocol does not show up.
    – Eugen
    Mar 18 '20 at 18:13
  • Thanks for that, added port and not getting the warning Mar 19 '20 at 7:32
1

There may be some confusion here. The command you're copy/pasting is the command to launch (in the context of a sandbox setting) a brand new fresh network that would immediately run the Carthage protocol from its genesis block. Is this really what you want to do?

0

I'm trying to start a sandbox and it's not working because of this error. That's how I found this stackExchange page. Any ideas? I'm getting the following:

tezos-client config reset
Warning:
  Failed to acquire the protocol version from the node
  Rpc request failed:
     - meth: GET
     - uri: http://localhost:8732/chains/main/blocks/head/protocols
     - error: Unable to connect to the node: "Unix.Unix_error(Unix.ECONNREFUSED, "connect", "")"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.