3

I tried installing ligo lang following the instructions here: https://ligolang.org/docs/intro/installation/

I have docker running, the bash install script runs fine, but I still get -bash: ligo: command not found

0

Put this snippet in a file named ligo

#!/bin/sh
docker run --user=`id -u` -v $PWD:$PWD -w $PWD ligolang/ligo:next "$@"

Then

chmod +x ligo
./ligo

does this work for you ?

1
  • I am having same issue, command given in documentation ligolang.org/docs/intro/installation does pull image only but doesn't create container. I tried above solution, it creates container as well but container gets exit immediately with error Error invoking remote method 'docker-start-container': Error: (HTTP code 400) unexpected - OCI runtime create failed: container_linux.go:367: starting container process caused: exec: "/root/ligo": stat /root/ligo: permission denied: unknown – murtza gondal Jun 4 at 7:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.