1

I'm trying to build from sources but when I run $ make I get the error:

File "docs/doc_gen/errors/dune", line 15, characters 1-52: 15 | (action (run %{lib:tezos-tooling:lint.sh} %{deps}))) ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ Error: 'action' was deleted in version 2.0 of the dune language. Use a rule stanza with the alias field instead make: *** [Makefile:20: all] Error 1

I think that I have the wrong version of dune (need 1.8.0, have 2.something) but I don't know much about opam and the ocaml ecosystem. How could I go about downgrading my version of dune? running ubuntu 19.10, I just installed ocaml and opam from apt

P.S. If someone could recommend a good tag for this kind of post that would be great. If one doesn't exist I would suggest adding a devops tag or something.

0

One workaround until dune 2 support is implemented is to pin dune to an earlier version, i.e.:

opam pin dune 1.11.4
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.