1

After upgrading to the latest version of Tezos, I received an error when running the baker: "Assert_failure vendors/irmin-pack/IO.ml:104:6". The node, endorser, accuser seem to run just fine.

Any idea what I have to do?

Thanks,

5
  • Can you give a complete log from your baker ? On which commit hash are you ? How do you run your baker ? – vect0r Jan 3 '20 at 13:12
  • Hey vect0r - thanks for the answer. That's about the full log. In the meantime, I have downloaded and loaded the latest snapshot from tezosshots.com but it mentions ./tezos-node run tezos-node: Error: Invalid data directory version '0.0.4' (expected '0.0.3'). Any idea how to solve that? – Mootjes mootjes Jan 3 '20 at 14:28
  • My bad - I was running the my old server again (mistake in custom script). It seems to be loading now. So the above error had to do with the upgrade of Irmin since the October release (tezos.gitlab.io/releases/october-2019.html). Reimporting a snapshot did the trick... – Mootjes mootjes Jan 3 '20 at 14:39
  • 1
    Yes. As it is a new storage backend, you need to "upgrade" your storage. The easiest way to get it is, indeed, importing a snapshot. So the baker fails directly, without other logs, ok. Is working now ? With the last storage and an up to date node/baker/… ? – vect0r Jan 3 '20 at 14:47
  • Yes you're right. Everything works fine now after recompiling and reimporting a snapshot. Thanks! – Mootjes mootjes Jan 9 '20 at 15:35
0

Solved by ensuring that the storage was upgraded an in accordance with the Tezos binaries (See op comments).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.