1

I'm trying to run flextesa sandoxed network in docker-compose.override.yml to enable it in development environments of a project:

  tz:
    container_name: tz
    image: registry.gitlab.com/tezos/flextesa:7dd2d93a-run
    command: flextesarl mini-net --size 2

However, docker-compose up tz fails as such :

$ docker-compose up tz
Creating tz ... done
Attaching to tz
tz          | Flextesa.mininet:  Clearing root: `/tmp/mininet-test` 
tz          | Flextesa.mininet:  Starting up the network. 
tz          | Flextesa.mininet: 
tz          |   Activating protocol ProtoALphaALphaALphaALphaALphaALphaALphaALphaDdp3zK
tz          | 
tz          | Flextesa.mininet:  Network started, preparing scenario. 
tz          | Flextesa.mininet:
tz          |   Registration-as-delegate:  Client: "C-N001", Key: "bootacc-0" 
tz          | Flextesa.mininet: Starting daemons:  Client: "C-N001", Key: "bootacc-0" 
tz          | Flextesa.mininet:
tz          |   Registration-as-delegate:  Client: "C-N000", Key: "bootacc-1" 
tz          | Flextesa.mininet: Starting daemons:  Client: "C-N000", Key: "bootacc-1" 
tz          | Flextesa.mininet:
tz          |   Registration-as-delegate:  Client: "C-N001", Key: "bootacc-2" 
tz          | Flextesa.mininet: Starting daemons:  Client: "C-N001", Key: "bootacc-2" 
tz          | Flextesa.mininet:
tz          |   Registration-as-delegate:  Client: "C-N000", Key: "bootacc-3" 
tz          | Flextesa.mininet: Starting daemons:  Client: "C-N000", Key: "bootacc-3" 
tz          | Flextesa.mininet: Pause  Sandbox is READY \o/ 
tz          | Flextesa.mininet: Please enter command:
tz          | Flextesa.mininet:
tz          |   Received End-of-File (Ctrl-D?) 
tz          |     Cannot pause because interactivity broken; killing everything and
tz          |     quitting.
tz          |   
tz          | Flextesa.mininet: Killing all processes.
tz          | Flextesa.mininet: Waiting for processes to all die.
tz          | Flextesa.mininet: ERROR: 
tz exited with code 2

Note that i'm trying to replace geth --dev running in compose service.

Same problem with:

$ docker run  registry.gitlab.com/tezos/flextesa:7dd2d93a-run flextesa mini-net --interactive=false
New contributor
jpic is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
2

Interesting that docker would send the end-of-file to the sandbox.

I'll look into a nicer solution but for now, with recent versions of flextesa, you can start the mini-net with --until-level option which is not interactive.

E.g. --until-level 20_000_000 should last a couple of years :)

  • Thanks a heap for your fast support !!! – jpic Nov 8 at 18:59

Your Answer

jpic is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.